NAME [Toc] [Back]
geocustoms - configure system language on multi-language systems
SYNOPSIS [Toc] [Back]
DESCRIPTION [Toc] [Back]
The geocustoms command manages default selection and retention/removal
of multiple languages installed on "ignited" (Instant Ignition)
systems. The geocustoms command is executed at first-boot (see
auto_parms(1M)) on ignited systems with multiple languages available.
In subsequent sessions, invoking the command /usr/sbin/geocustoms
starts geocustoms. When invoked with no options, geocustoms runs
interactively, either with a graphical display if the DISPLAY
environment parameter is set and usable, otherwise with a terminal
Options [Toc] [Back]
-l locale Non-interactively set the LANG parameter, and all
other appropriate dependencies, based on the value of
locale. (To view all locales available on the
system, run locale -a.) If the locale argument is not
a valid option for the system, an error message is
issued and the graphical or terminal user interface
(UI) appears, as if the -l option were not used.
If the argument to the -l option is SET_NULL_LOCALE, locale parameters
are set to NULL by default. A null locale causes programs to execute
without using localized message catalogs, which can increase system
performance. All HP-UX messages appear in English if the locale is
set to NULL.
The geocustoms command must be invoked by a user with appropriate
If geocustoms is invoked directly by the user rather than
automatically at first-boot, it might be necessary to log out and log
in again for language changes to take effect.
EXTERNAL INFLUENCES [Toc] [Back]
The geocustoms command writes default values to system configuration
files for the following environment parameters: LANG, LC_ALL,
LC_CTYPE, LC_COLLATE, LC_MONETARY, LC_NUMERIC, LC_TIME, and
International Code Set Support [Toc] [Back]
Native Language Support (NLS)
If present, standard message catalogs reside in /usr/lib/nls and the
geocustoms command uses them. If standard message catalogs are not
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
installed on the system, all messages appear in English, which is
standard NLS behavior.
All European languages for CDE (Common Desktop Environment) are
supported. For HP-UX 11i Version 1 this includes English, French,
German, Italian, Spanish and Swedish. All prompts and logging
messages are localized.
Locale (Language Variant) names are always localized in accordance
with standard NLS behavior.
Note: NLS is extended to allow multiple "fonts" at the same time on
the initial geocustoms graphical screen through use of bitmapped
RETURN VALUES [Toc] [Back]
0 Successful completion and/or clean exit from command.
1 Command unable to complete all objectives.
DIAGNOSTICS [Toc] [Back]
The non-interactive geocustoms command does not write to stdout.
Standard Error [Toc] [Back]
The geocustoms command writes to stderr and to /var/adm/sw/lang.log.
It only writes to stderr in case of command line error or a request
for syntax (the conventional -? option). Any UI error messages appear
via an error window.
Logging [Toc] [Back]
Both interactive and non-interactive sessions log summary events in
EXAMPLES [Toc] [Back]
To set the default system language non-interactively to German:
/usr/sbin/geocustoms -l de_DE.iso88591
DEPENDENCIES [Toc] [Back]
This product is designed for compatibility with releases including and
after HP-UX 11.00 running a Common Desktop Environment (CDE). No
attempt was made to support the Visual User Environment (VUE).
Note: If language bundles are marked for removal it can cause a delay
of several minutes in swagentd(1M) at the next system boot.
Limitations [Toc] [Back]
The geocustoms command does not do the following:
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004
+ Manage languages at the codeset level.
+ Provide a user interface for Asian languages.
+ Manage keyboard selection.
+ Create or remove locale definitions.
+ Provide a special interface for restoring or adding languages
to the system from depots or media.
FILES [Toc] [Back]
The command itself.
Directory containing NLS language files, as discussed in Native
Language Support above.
System configuration files modified by geocustoms.
Logfile created by geocustoms.
AUTHOR [Toc] [Back]
The geocustoms command was developed by HP.
SEE ALSO [Toc] [Back]
locale(1), auto_parms(1M), swinstall(1M), swlist(1M), swremove(1M),
STANDARDS CONFORMANCE [Toc] [Back]
POSIX.2, UNIX95 (SPEC1170 and XPG4).
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: Sep 2004 [ Back ]