vlan(7) vlan(7)
NAME [Toc] [Back]
vlan - virtual LANs (VLANs)
SYNOPSIS [Toc] [Back]
/usr/sbin/lanadmin -V create vlanid vlanid [pri priority]
[tos ToS_value] [vppa vppa] [name name] [tos_override level]
[pri_override level] ppa
/usr/sbin/lanadmin -V delete vppa
/usr/sbin/lanadmin -V modify [vlanid vlanid] [pri priority]
[tos ToS_value] [name name]
[tos_override level] [pri_override level] vppa
/usr/sbin/lanadmin -V scan
/usr/sbin/lanadmin -V info vppa
/usr/sbin/lanadmin -V basevppa
/usr/sbin/lanadmin -V help
/usr/sbin/lanadmin lanadmin -p ppa
DESCRIPTION [Toc] [Back]
VLANs are logical, or "virtual," network segments that can span
multiple physical network segments. A primary benefit of VLANs is that
they can isolate broadcast and multicast traffic by determining which
destinations should receive that traffic, thereby making better use of
switch and end-station resources.
The commands described here are for interactive administration of HPUX
virtual LANs (VLANs).
Changes made to VLANs interactively with the lanadmin -V command will
not be preserved between system reboots. You must either use the SAM
interface or manually edit the /etc/rc.config.d/vlanconf configuration
file in order for changes to be preserved across reboots.
lanadmin -V lanadmin options to create, modify, delete, and query
VLANs.
lanadmin -p lanadmin option to see if upper-layer protocols or
applications are running (used before deleting VLANs)
lanadmin Options
The lanadmin command options for VLANs are described as follows:
lanadmin -V create vlanid vlanid [pri priority]
[tos ToS_value] [vppa vppa] [name name] [tos_override level]
[pri_override level]
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
A VLAN ID, vlanid, uniquely identifies the VLAN to which a frame
belongs. The valid range for vlanid is 0-4094.
The landamin -V create command options are:
pri priority priority is the 802.1p priority in the tag in
the frame header. Switches use the 802.1p
priority. The valid range for priority is 0-7.
The default is 0.
tos ToS_value ToS is the IP precedence in the IP header.
Switches ignore ToS. Routers may use it. The
valid range is 0-255. The default is 0.
vppa vppa A virtual PPA (VPPA) is the PPA associated with
a VLAN. They are virtual because they do not
have a unique hardware instance.
name name An optional name for the VLAN. The default
value of VLAN name is null string ("").
However, lanadmin displays this as UNNAMED.
tos_override level
ToS override provides a mechanism to override
the IP level precedence in the header of an
inbound IP packet. ToS override level strings
for inbound traffic are:
IP_HEADER [Toc] [Back]
ToS value in the IP header will be used.
ETHER_HEADER [Toc] [Back]
Ether header 802.1p priority will be
converted to ToS value.
CONF_TOS [Toc] [Back]
Your specified ToS value will be used.
CONF_PRI [Toc] [Back]
Your specified 802.1 priority value will
be converted to ToS.
pri_override level
Priority override provides a mechanism to
convert IP level precedence (IPV4 ToS octet) to
link level 802.1p user priority. Priority
override applies to outbound frames only.
Priority override level strings for outbound
traffic are:
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
CONF_PRI [Toc] [Back]
Your specified priority value will be
used.
IP_HEADER [Toc] [Back]
IP header ToS will be converted to 802.1p
priority.
CONF_TOS [Toc] [Back]
Your specified ToS value will be converted
to 802.1 priority.
lanadmin -V scan
Identifies all VLANs and their properties.
lanadmin -V info vppa
Identifies a single VLAN and its properties. The command returns
0 on successful completion and -1 on failure.
lanadmin -V basevppa
For finding the minimum acceptable value for a virtual PPA
(VPPA).
lanadmin -p
lanadmin option to see if for upper-layer protocols or
applications are running (used before deleting VLANs)
lanscan Options
The lanscan command shows the number of interfaces available on the
system such as lan0, lan1. The following lanscan options can be used
to display vlan information.
lanscan -a displays the MAC addresses of all the interfaces on the
system.
lanscan -i displays the names of all the interfaces on the system.
lanscan -m displays the MAC type for all the interfaces
lanscan -n displays the Network Management IDs for all the
interfaces
lanscan -p displays the PPA or VPPA number for all the interfaces
lanscan -v displays the output in verbose mode with detailed
information.
EXAMPLES [Toc] [Back]
Following are explanations of the usage of all the new and existing
lanadmin and lanscan commands and how they can be used to work with
virtual LANs (VLANs).
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
Creating a VLAN [Toc] [Back]
When VLANs are configured on a LAN card, the lanscan output under
Hardware Path shows VLANx, where x is a unique VLAN interface number.
To create VLANs, you use either SAM or the lanadmin create command.
There are multiple required and optional arguments for creating VLANs.
If you don't specify any or all of the optional arguments, the default
values shown at the beginning of this man page are used.
You can either specify a virtual PPA (VPPA) number greater than the
minimum allowed VPPA number (5000) or allow the system to assign a
VPPA number.
Suppose you want to create a VLAN with a VPPA of 6050 and a vlanid of
4 on PPA 0, you can use the following command:
#lanadmin -V create vlanid 4 vppa 6050 0
Upon successful creation, the following message is displayed:
Successfully configured.
lan6050: vlanid 4 name UNNAMED pri 0 tos 0
tos_override IP_HEADER pri_override CONF_PRI ppa 0
The message shows that you have successfully created VLAN 6050 on the
system. If you do not assign any name to a VLAN, a standard string
"UNNAMED" is displayed as the name.
To create a VLAN on PPA 1, while letting the system generate the VPPA,
you would use the following command to create a VLAN with lanid 75,
priority 3, ToS 100, name honey, ToS override value CONF_TOS and
priority override value IP_HEADER:
#lanadmin -V create vlanid 75 pri 3 tos 100 name honey
tos_override CONF_TOS pri_override IP_HEADER 1
Upon successful creation, the following message is displayed:
Successfully configured.
lan5000: vlanid 75 name honey pri 3 tos 100
tos_override CONF_TOS pri_override IP_HEADER ppa 1
The system has allotted the VPPA 5000 and successfully created a VLAN
with the specified properties.
Let us create one more VLAN on interface 1 with different properties.
#lanadmin -V create vlanid 76 pri 2 tos 200 name bee tos_override
ETHER_HEADER pri_override IP_HEADER 1
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
Upon successful creation, the following message is displayed:
Successfully configured.
lan5001: vlanid 76 name bee pri 2 tos 200
tos_override ETHER_HEADER pri_override IP_HEADER ppa 1
Let us take a look at the lanscan, lanadmin -V scan, and lanscan -v
snapshots of the system after successful creation of 3 VLANs--VLAN
6050 on PPA 0 and VLAN 5000 and 5001 on PPA 1.
#lanscan
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
0/4/0/0 0x001083FF9951 0 UP lan0 snap0 1 ETHER Yes 119
VLAN6050 0x001083FF9951 6050 UP lan6050 snap6050 14 ETHER Yes 119
1/4/0/0 0x006023456789 1 DOWN lan1 snap1 2 ETHER Yes 119
VLAN5000 0x006023456789 5000 DOWN lan5000 snap5000 15 ETHER Yes 119
VLAN5001 0x006023456789 5001 DOWN lan5001 snap5001 16 ETHER Yes 119
There are a few things to be noted from the above output:
+ VPPAs have VLANx as their Hardware Path where x is a unique
number.
+ The VPPA has the same MAC address as the PPA on which it is
created.
+ The VPPA has the same Hardware State as the PPA on which it is
created.
+ The VPPA has a PPA associated with it.
+ In the lanscan output, VPPA information is shown immediately
after the PPA on which it was created. For example, information
about VLAN0 is displayed after lan0 information. Information
about VLAN1 and VLAN2 is displayed after lan1 information because
VLAN1 and VLAN2 are associated with lan1.
The other properties which are not visible from the snapshot above but
are common between the VPPA and the PPA on which it is created are
Speed and MTU setting. You can verify this by using the lanadmin
commands to find out Speed and MTU, respectively:
lanadmin -a vppa
lanadmin -s vppa
lanadmin -m vppa
Now let's explore the outputs of lanadmin -V scan and lanscan -p.
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
#lanadmin -V scan
VLAN Physical VLAN Pri Pri ToS ToS NAME
Interface Interface ID Override Override
Name Level Level
lan6050 lan0 4 0 CONF_PRI 0 IP_HEADER UNNAMED
lan5000 lan1 75 3 IP_HEADER 100 CONF_TOS honey
lan5001 lan1 76 2 IP_HEADER 200 ETHER_HEADER bee
#lanscan -p
0
6050
1
5000
5001
You can alternatively use the lanadmin -V info vppa command to get
information about a specific VPPA. Let's say you are interested in
VPPA 6050. The following command will get information regarding VPPA
6050.
#lanadmin -V info 6050
VLAN Physical VLAN Pri Pri ToS ToS NAME
Interface Interface ID Override Override
Name Level Level
lan6050 lan0 4 0 CONF_PRI 0 IP_HEADER UNNAMED
Note that information related only to VPPA 6050 is displayed as a
result of the info command.
Let's examine the lanscan -v output now. For the sake of simplicity,
the output from only lan0, lan1, and newly created VPPA's has been
displayed.
#lanscan -v
-----------------------------------------------------------------------
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
0/4/0/0 0x001083FF9951 0 UP lan0 snap0 1 ETHER Yes 119
Extended Station LLC Encapsulation
Address Methods
0x001083FF9951 IEEE HPEXTIEEE SNAP ETHER NOVELL
Driver Specific Information
gelan
-----------------------------------------------------------------------
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
VLAN6050 0x001083FF9951 6050 UP lan6050 snap6050 14 ETHER Yes 119
Hewlett-Packard Company - 6 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
Extended Station LLC Encapsulation
Address Methods
0x001083FF9951 IEEE HPEXTIEEE SNAP ETHER NOVELL
Driver Specific Information
vlan
Vlan ID Phy-PPA Priority ToS Priority-Override ToS-Override Name
4 0 0 0 CONF_PRI IP_HEADER UNNAMED
-----------------------------------------------------------------------
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
1/4/0/0 0x006023456789 1 DOWN lan1 snap1 1 ETHER Yes 119
Extended Station LLC Encapsulation
Address Methods
0x006023456789 IEEE HPEXTIEEE SNAP ETHER NOVELL
Driver Specific Information
btlan
-----------------------------------------------------------------------
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
VLAN5000 0x006023456789 5000 DOWN lan5000 snap5000 15 ETHER Yes 119
Extended Station LLC Encapsulation
Address Methods
0x006023456789 IEEE HPEXTIEEE SNAP ETHER NOVELL
Driver Specific Information
vlan
Vlan ID Phy-PPA Priority ToS Priority-Override ToS-Override Name
75 1 3 64 CONF_PRI IP_HEADER honey
-----------------------------------------------------------------------
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
VLAN5001 0x006023456789 5001 DOWN lan5001 snap5001 15 ETHER Yes 119
Extended Station LLC Encapsulation
Address Methods
0x006023456789 IEEE HPEXTIEEE SNAP ETHER NOVELL
Driver Specific Information
vlan
Vlan ID Phy-PPA Priority ToS Priority-Override ToS-Override Name
76 1 2 200 IP_HEADER ETHER_HEADER bee
-----------------------------------------------------------------------
You can configure an IP address on the VPPAs. Let's consider
configuring VPPA 6050 with IP address 192.1.1.1. This can be done
using the ifconfig command as it would be done for any PPA.
Hewlett-Packard Company - 7 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
#ifconfig lan6050 192.1.1.1 netmask 0XFFFFF800 up.
The snapshots for lanscan -v, lanscan, lanadmin -V info, and lanadmin
-V scan remain the same.
Modifying a VLAN [Toc] [Back]
You can modify a vlan while it is supporting traffic. If you modify a
vlanid, traffic will be sent and received on the new vlanid but not on
the former vlanid.
Let's try to modify the properties of the VPPAs already created, and
also study the corresponding changes in various lanadmin and lanscan
command outputs. Let's modify the vlanid, priority, and name of VPPA
6050. The following command will change the vlanid from 4 to 100,
priority value from 0 to 7, and the name from the default name to
"candy" for VPPA 6050.
#lanadmin -V modify vlanid 100 priority 7 name candy 6050
Successfully modified lan6050.
Old value: vlanid 4 pri 0 name UNNAMED
New value: vlanid 100 pri 7 name candy
Let's modify the properties tos, tos_override and pri_override for
VPPA 5000. The following command can be used to change tos to 64 from
100, tos_override to IP_HEADER from CONF_TOS and pri_override to
CONF_PRI from IP_HEADER.
#lanadmin -V modify tos 64 tos_override IP_HEADER pri_override CONF_PRI
5000
Successfully modified lan5000.
Old value: tos 100 tos_override CONF_TOS pri_override IP_HEADER
New value: tos 64 tos_override IP_HEADER pri_override CONF_PRI
Let's take a look at the lanadmin -V scan, lanadmin -V info, and
lanscan -v snapshot of the system after successful modification of 2
VPPAs: VPPA 6050 on PPA 0 and VPPA 5000 on PPA 1. The lanscan
snapshot will remain the same as before the modification; however you
can see differences in the lanscan -v and lanadmin -V scan snapshots
before and after modification.
#lanadmin -V scan
VLAN Physical VLAN Pri Pri ToS ToS NAME
Interface Interface ID Override Override
Name Level Level
lan6050 lan0 100 7 CONF_PRI 0 IP_HEADER candy
lan5000 lan1 75 3 CONF_PRI 64 IP_HEADER honey
lan5001 lan1 76 2 IP_HEADER 64 ETHER_HEADER bee
Hewlett-Packard Company - 8 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
You can alternatively use the lanadmin -V info vppa command to get
information about a specific VPPA. Let's say you are interested in
VPPA 6050. The following command will get information regarding VPPA
6050.
#lanadmin -V info 6050
VLAN Physical VLAN Pri Pri ToS ToS NAME
Interface Interface ID Override Override
Name Level Level
lan6050 lan0 100 7 CONF_PRI 0 IP_HEADER candy
Deleting a VLAN [Toc] [Back]
Before deleting a VLAN, ensure that there are no applications or upper
layer protocols active on the VLAN by running:
#lanadmin -p VPPA
This command displays the applications and commands that are presently
using the interface. For example, if the only thing done to lan5000
is configure an IP address, the lanadmin -p command output would look
like:
#lanadmin -p 5000
ifconfig
ifconfig
Since ifconfig command is used to configure an IP address the same is
displayed. There are two entries because when an IPv4 address is
configured using ifconfig, it configures both IP and ARP on the
interface.
To remove the IP and ARP streams, do:
#ifconfig lan5000 unplumb
The lanadmin -p 5000 output will not show any entries now, which means
the interface can be deleted. To delete this VLAN, use the delete
option as follows:
#lanadmin -V delete 5000
The lanadmin -p PPA command always displays the commands that use or
are configured on the interface. Lets take another example, to delete
the interface lan5001
#lanadmin -p 5001
ifconfig
ifconfig
Hewlett-Packard Company - 9 - HP-UX 11i Version 2: Sep 2004
vlan(7) vlan(7)
mib2agt
scopeux
In addition to IP and ARP being configured on the interface, two
applications, mib2agt and scopeux, are using the interface. These
applications are started during system bootup via the startup scripts
/sbin/rc2.d/S565SnmpMib2 and /sbin/rc2.d/S810mwa, respectively. To
stop these utilities, run the stop sequence of the scripts. To delete
the lan5001 interface, type the following commands:
#ifconfig lan5001 unplumb
#/sbin/rc2.d/S565SnmpMib2 stop
#/sbin/rc2.d/S810mwa stop
Now, lanadmin -p 5001 will not display anything, and the interface can
be deleted.
Once the interface is deleted, you can restart the script by issuing
the start sequence:
#/sbin/rc2.d/S565SnmpMib2 start
#/sbin/rc2.d/S810mwa start
NOTE: The start and stop sequence of the startup scripts will affect
all the interfaces on the system, and they must be restarted once the
delete operation is completed.
The above examples are not restrictive. The applications that use the
interfaces depend on your environment.
WARNINGS [Toc] [Back]
Changes made to VLANs interactively with the lanadmin -V command will
not be preserved between system reboots. You must either use the SAM
interface or manually edit the /etc/rc.config.d/vlanconf configuration
file in order for changes to be preserved across reboots.
AUTHOR [Toc] [Back]
lanadmin was developed by HP.
SEE ALSO [Toc] [Back]
lanadmin(1M), lanscan(1M), Using HP-UX VLANs.
IEEE 802.1d, IEEE 802.1Q
Hewlett-Packard Company - 10 - HP-UX 11i Version 2: Sep 2004 [ Back ] |