dlpi(7) dlpi(7)
NAME [Toc] [Back]
dlpi - data link provider interface
DESCRIPTION [Toc] [Back]
This manual page gives a brief description on DLPI (the data link
provider interface) and how to interface with the set of API's that
are provided by DLPI.
HP-UX DLPI serves as a Layer 2 (Data Link Layer) of an OSI
architecture. DLPI serves as an interface between LAN device drivers
and DLPI users. DLPI is intended for use by experienced network users
only.
HP-UX DLPI has two broader sets of interface. The first set of
interfaces are provided as per the DLPI 2.0 standard and the second
set that are HP extensions to the standard.
HP-UX DLPI also provides interfaces to device drivers to interface
with STREAMS modules and DLPI applications.
For STREAMS Modules and DLPI Applications [Toc] [Back]
Hewlett-Packard's implementation of DLPI is a Style 2 service
provider. The Style 2 provider requires a DLS user to identify a PPA
explicitly, using a special attach service primitive. Refer to the
lan(7) manual page for more information on PPA.
HP DLPI offers the following services to STREAMS modules and DLPI
applications:
+ Clone (maximum of 3992) and non-clone (maximum of 100) access.
+ Support for Ethernet/IEEE802.3, FDDI and Token Ring
interfaces.
+ Support for connectionless and connection-mode services
(connection-mode services are supported only over IEEE802.3
and Token Ring).
+ Supports raw-mode services.
+ I_STR ioctl is supported for doing device-specific control and
diagnostic requests.
+ Support for third-party device drivers.
+ Support for all levels of promiscuous mode.
HP DLPI does not offer the following for STREAMS modules and DLPI
applications:
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
dlpi(7) dlpi(7)
+ Quality of Service (QOS) management.
+ Connection Management STREAMS: DL_SUBS_BIND_REQ and
DL_SUBS_UNBIND_REQ over connection-oriented STREAMS.
+ Acknowledged connectionless-mode services.
The DLPI requests based on DLPI 2.0 standard are defined in <dlpi.h>;
see dlpi(4). HP extensions for DLPI are defined in <dlpi_ext.h>; see
dlpi_ext(4).
Device File Format [Toc] [Back]
To access LAN drivers via DLPI interface, DLS users must use the
following device files:
Name Type Major # Minor # Access Type
---- ---- ------- ------- -----------
/dev/dlpi c 72 0x77 Clone access
/dev/dlpiX c 119 0xX Non-Clone access
For Device Drivers [Toc] [Back]
HP-UX DLPI is of non-native design. The drivers and DLPI are not
coupled together and exists as individual components on the system.
The non-native DLPI supports two kinds of drivers. Tightly coupled
and loosely coupled drivers.
DLPI provides interfaces to tightly coupled and loosely coupled
drivers. DLPI serves as a sole interface to DLS users for tightly
coupled drivers. Whereas, a loosely coupled driver depends on DLPI
only to provide information to user-space command lanscan(1M) for
display purposes.
The interfaces for device drivers is defined in <dlpi_drv.h>, see
dlpi_drv(4).
DLPI provides the following functionality for tightly coupled drivers:
+ Infrastructure that allows drivers to communicate with upper
layer STREAMS modules or applications.
+ Infrastructure for protocol, multicast and promiscuous
processing.
+ Infrastructure for asynchronous processing of control.
+ Inbound frame processing.
+ Processing link up and down events.
+ Repository for all registered interfaces and associated
information.
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
dlpi(7) dlpi(7)
+ Outbound processing before hand off to physical drivers.
DLPI provides its services through three header files that are
exported. The header files <dlpi.h> and <dlpi_ext.h> are for user
space applications and kernel level STREAMS modules. The header file
<dlpi_drv.h> is for physical and logical drivers.
WARNINGS [Toc] [Back]
Various implementations of DLPI exists within HP-UX for special
technologies like ATM, Hyper Fabric, etc.; but the DLPI that supports
LAN class drivers (tightly coupled) is the one covered by this manual
page.
AUTHOR [Toc] [Back]
dlpi was developed by HP, based on DLPI 2.0 standard.
SEE ALSO [Toc] [Back]
lanscan(1M), dlpi(4), dlpi_drv(4), dlpi_ext(4), lan(7).
DLPI Programmer's Guide, 2003, Hewlett-Packard
Driver Development Guide, Hewlett-Packard
Device Driver Reference, Hewlett-Packard
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003 [ Back ] |