*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> mman (5)              
Title
Content
Arch
Section
 

Contents


 mman(5)                                                             mman(5)




 NAME    [Toc]    [Back]
      mman - memory mapping definitions

 SYNOPSIS    [Toc]    [Back]
      #include <sys/mman.h>

 DESCRIPTION    [Toc]    [Back]
      The <sys/mman.h> header defines the following symbolic constants for
      use with the madvise() function:

           MADV_NORMAL              No further special treatment.
           MADV_RANDOM              Expect random page references.
           MADV_SEQUENTIAL          Expect sequential page references.
           MADV_WILLNEED            Will need these pages.
           MADV_DONTNEED            Will not need these pages.
           MADV_SPACEAVAIL          Ensure that resources are reserved.

      The following symbolic constants are defined for use with the mmap()
      and mprotect() functions:

           PROT_READ                Region can be read.
           PROT_WRITE               Region can be written.
           PROT_EXEC                Region can be executed.
           PROT_NONE                Region cannot be accessed.

      The following symbolic constants are defined for use with the mmap()
      function:

           MAP_FILE                 Map a file.
           MAP_ANONYMOUS            Map an unnamed memory region.
           MAP_VARIABLE             Place region at implementation-computed
                                    address.
           MAP_FIXED                Place region at specified address.
           MAP_SHARED               Share changes made to mapped region.
           MAP_PRIVATE              Changes to mapped region are private to
                                    a process.

      The following symbolic constants are defined for use with the msync()
      function:

           MS_SYNC                  Perform synchronous writes.
           MS_ASYNC                 Perform asynchronous writes.
           MS_INVALIDATE            Invalidate cached pages.

      The following symbolic constants are defined for use with the
      msem_init(), msem_lock(), and msem_unlock() functions:

           MSEM_LOCKED              Create semaphore in locked state.
           MSEM_UNLOCKED            Create semaphore in unlocked state.
           MSEM_IF_NOWAIT           Do not wait if semaphore is locked.




 Hewlett-Packard Company            - 1 -   HP-UX 11i Version 2: August 2003






 mman(5)                                                             mman(5)




           MSEM_IF_WAITERS          Do not unlock if semaphore has no
                                    waiters.

      The typedef struct msemaphore is defined for use with the msem_init(),
      msem_lock(), msem_unlock(), and msem_remove() functions.

 SEE ALSO    [Toc]    [Back]
      mmap(2), munmap(2), mprotect(2), msync(2), madvise(2), msem_init(2),
      msem_remove(2), msem_lock(2), msem_unlock(2).


 Hewlett-Packard Company            - 2 -   HP-UX 11i Version 2: August 2003
[ Back ]
      
      
 Similar pages
Name OS Title
mprotect IRIX set protection of memory mapping
mprotect HP-UX set or check protection of memory mapping
mprotect Tru64 Modify access protections of memory mapping
DtPrint HP-UX print definitions
Tttt_c HP-UX ToolTalk definitions
Tttttk HP-UX ToolTalk definitions
DtHelp HP-UX help services definitions
DtHelpQuickD HP-UX DtHelpQuickDialog definitions
DtHelpDialog HP-UX DtHelpDialog definitions
_procedure_string_table Tru64 locations in program and definitions
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service