gated.conf(4) gated.conf(4)
NAME [Toc] [Back]
gated.config - GateDaemon Configuration Guide
SYNOPSIS [Toc] [Back]
/etc/gated.conf
DESCRIPTION [Toc] [Back]
Configuration Overview
+ Introduction
+ Statement Summary
+ Preferences and Route Selection
+ Trace Statements and Global Options
+ Directive Statements
+ Options Statements
+ Interface Statements and Configuration
+ Definition Statements
Protocol Statements [Toc] [Back]
+ Protocol Overview
+ Interior gateway protocols (igps)
+ RIP, HELLO, OSPF
+ Exterior gateway protocols (egps)
+ EGP, BGP
+ ICMP Statement
+ Redirect Statement
+ Router Discovery Statement
+ Kernel Interface
+ Static Routes
Control Statements [Toc] [Back]
+ Route filtering
+ Matching AS paths
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
+ Route Importation
+ Route Exportation
+ Route Aggregation
Appendices [Toc] [Back]
+ Glossary of Terms
+ References
Introduction to Configuring GateD [Toc] [Back]
Syntax
The gated configuration file consists of a sequence of statements
terminated by a semi-colon (`;'). Statements are composed of tokens
separated by white space, which can be any combination of blanks, tabs
and newlines. This structure simplifies identification of the parts of
the configuration associated with each other and with specific
protocols. Comments may be specified in either of two forms. One form
begins with a pound sign (`#') and runs to the end of the line. The
other form, C style, starts with a `/*' and continues until it reaches
`*/'.
Syntax description conventions [Toc] [Back]
Keywords and special characters that the parser expects exactly are
displayed using bold type. Parameters are displayed in italic variable
definition style. Parameters shown in square brackets (`[' and `]')
are used to show optional keywords and parameters. The vertical bar
(`|') is used to indicate between a choice of optional parameters.
Parentheses (`(' and `)') are used to group keywords and parameters
when necessary.
For example, in the syntax description:
[ backbone | ( area area ) ]
The square brackets say that either parameter is optional. The
keywords are backbone and area. The vertical bar indicates that
either ``backbone'' or ``area area'' may be specified. Since area is
in the variable definition style, it is a parameter that needs to be
provided.
Statement Grouping [Toc] [Back]
The configuration statements and the order in which these statements
appear divide gated.conf into options statements, interface
statements, definition statements, protocol statements, static
statements, control statements, and aggregate statements. Entering a
statement out of order causes an error when parsing the configuration
file.
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
Two other types of statements do not fit in these categories:
%directive statements and %trace statements. These statements provide
instructions to the parser and control tracing from the configuration
file. They do not relate to the configuration of any protocol and may
occur anywhere in the gated.conf file.
Statement Summary [Toc] [Back]
A summary table of the configuration statements (in the configuration
statement summary) lists each GateD configuration statement by name,
identifies the statement type, and provides a short synopsis of the
command function. More detailed definitions and descriptions of each
of the eight classes of GateD statements follow in separate sections.
GateD Configuration Statement Summary [Toc] [Back]
The GateD configuration commands are summarized below. The table lists
each command by name, identifies the statement type, and gives a
synopsis of the statement function:
Summary of GateD Configuration Statements [Toc] [Back]
%directory (directive) sets the directory for include
files.
%include (directive) includes a file into gated.conf.
traceoptions (trace) specifies which events are traced.
options (definition) defines GateD options.
interfaces (definition) defines GateD interfaces.
autonomoussystem (definition) defines the AS number.
routerid (definition) defines the originating router
(BGP, OSPF).
martians (definition) defines invalid destination
addresses.
rip (protocol) enables RIP protocol.
hello (protocol) enables HELLO protocol.
isis (protocol) enables ISIS protocol.
kernel (protocol) configures kernel interface
options.
ospf (protocol) enables OSPF protocol.
egp (protocol) enables EGP protocol.
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
bgp (protocol) enables BGP protocol.
redirect (protocol) configures the processing of ICMP
redirects.
icmp (protocol) configures the processing of
general ICMP packets.
static (static) defines static routes.
import (control) defines which routes to import.
export (control) defines which routes to export.
aggregate (control) defines which routes to aggregate.
generate (control) defines which routes to generate.
Preference [Toc] [Back]
Preference is the value GateD uses to order preference of routes from
one protocol or peer over another. Preference can be set in the GateD
configuration files in several different configuration statements.
Preference can be set based on network interface over another, from
one protocol over another, or from one remote gateway over another.
Preference may not be used to control the selection of routes within
an igp, this is accomplished automatically by the protocol based on
metric. Preference may be used to select routes from the same egp
learned from different peers or autonomous systems. Each route has
only one preference value associated with it, even though preference
can be set at many places in the configuration file. Simply, the last
or most specific preference value set for a route is the value used.
(See Glossary of Terms: Preference.) The preference value is an
arbitrarily assigned value used to determine the order of routes to
the same destination in a single routing database. The active route is
chosen by the lowest preference value. Some protocols implement a
second preference (preference2), sometimes referred to as a tiebreaker.
Selecting a route [Toc] [Back]
+ The route with the best (numerically smallest) preference is
preferred.
+ If the two routes have the same preference, the route with the
best (numerically smallest) preference2 (also known as a tiebreaker)
is preferred.
+ A route learned from a igp is preferred to a route learned
from an egp. Least preferred is a route learned indirectly by
an igp from an egp.
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
+ If AS path information is available, it is used to help
determine the most preferred route.
+ A route with an AS path is preferred over one without an AS
path.
+ If the AS paths and origins are identical, the route with
the lower metric is preferred.
+ A route with an AS path origin of igp is preferred over a
route with an AS path origin of egp. Least preferred is an
AS path with an unknown origin.
+ A route with a shorter AS path is preferred.
+ If both routes are from the same protocol and AS, the one with
the lowest metric is preferred.
+ The route with the lowest numeric next-hop address is used.
Assigning preferences [Toc] [Back]
A default preference is assigned to each source from which GateD
receives routes. Preference values range from 0 to 255 with the lowest
number indicating the most preferred route.
The following table summarizes the default preference values for
routes learned in various ways. The table lists the statements (some
of these are clauses within statements) that set preference, and shows
the types of routes to which each statement applies. The default
preference for each type of route is listed, and the table notes
preference precedence between protocols. The narrower the scope of the
statement, the higher precedence its preference value is given, but
the smaller the set of routes it affects.
Preference Of Defined by Statement Default
___________________________________________________________________
direct connected networks interface 0
OSPF routes ospf 10
IS-IS level 1 routes isis level 1 15
IS-IS level 2 routes isis level 2 18
internally generated default gendefault 20
redirects redirect 30
routes learned via route socket kernel 40
static routes from config static 60
ANS SPF (SLSP) routes slsp 70
HELLO routes hello 90
RIP routes rip 100
point-to-point interface 110
routes to interfaces that are down interfaces 120
aggregate/generate routes aggregate/generate 130
OSPF AS external routes ospf 150
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
BGP routes bgp 170
EGP egp 200
Sample Preference Specifications [Toc] [Back]
interfaces {
interface 138.66.12.2 preference 10 ;
} ;
rip yes {
preference 90 ;
} ;
import proto rip gateway 138.66.12.1 preference 75 ;
In these statements the preference applicable to routes learned via
RIP from gateway 138.66.12.1 is 75. The last preference applicable to
routes learned via RIP from gateway 128.66.12.1 is defined in the
accept statement. The preference applicable to other RIP routes is
found in the rip statement. The preference set on the interface
statement applies only to the route to that interface.
Trace Statements [Toc] [Back]
Trace statements control tracing options. The GateD tracing options
may be configured at many levels. Tracing options include the file
specifications, control options, and global and protocol specific
tracing options. Unless overridden, tracing options from the next
higher level are inherited by lower levels. For example, BGP peer
tracing options are inherited from BGP group tracing options, which
are inherited from global BGP tracing options, which are inherited
from global GateD tracing options. At each level tracing
specifications override the inherited options.
Global tracing options [Toc] [Back]
There are two types of global options, those which only affect global
operations and those which have potential significance to protocols.
Global significance only [Toc] [Back]
The trace flags that only have global significance are:
parse Trace the lexical analyzer and parser. Mostly used by
GateD developers for debugging.
adv Trace the allocation of and freeing of policy blocks.
Mostly used by the GateD developers for debugging.
symbols Used to trace symbols read from the kernel at startup.
The only useful way to specify this level of tracing is
via the -t option on the command line since the symbols
are read from the kernel before parsing the
configuration file.
iflist Used to trace the reading of the kernel interface list.
It is useful to specify this with the -t option on the
Hewlett-Packard Company - 6 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
command line since the first interface scan is done
before reading the configuration file.
Protocol significance [Toc] [Back]
The options flags that have potential significance to protocols are:
all Turn on all of the following.
general A shorthand notation for specifying both normal and
route.
state Trace state machine transitions in the protocols.
normal Trace normal protocols occurrences. Abnormal protocol
occurrences are always traced.
policy Trace application of protocol and user-specified policy
to routes being imported and exported.
task Trace system interface and processing associated with
this protocol or peer.
timer Trace timer usage by this protocol or peer.
route Trace routing table changes for routes installed by
this protocol or peer.
Not all of the above options apply to all of the protocols. In some
cases their use does not make sense (for instance, RIP does not have a
state machine) and in some instances the requested tracing has not
been implemented (such as RIP support of the policy option).
It is not currently possible to specify packet tracing from the
command line. This is because a global option for packet tracing would
potentially create too much output.
When protocols inherit their tracing options from the global tracing
options, tracing levels that do not make sense (such as parse, adv and
packet tracing options) are masked out.
Global tracing statements have an immediate effect, especially parsing
options that effect the parsing of the configuration file. Tracing
values inherited by protocols specified in the configuration file are
initially inherited from the global options in effect as they are
parsed, unless they are overridden by more specific options. After the
configuration file is read, tracing options that were not explicitly
specified are inherited from the global options in effect at the end
of the configuration file.
Packet tracing [Toc] [Back]
Tracing of packets is very flexible. For any given protocol there are
Hewlett-Packard Company - 7 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
one or more options for tracing packets. all protocols allow use of
the packets keyword allows for tracing all packets sent and received
by the protocol. most protocols have other options for limiting
tracing to a useful subset of packet types. These tracing options can
be further controlled with the following modifiers:
detail detail must be specified before send or recv. Normally
packets are traced in a terse form of one or two lines.
When detail is specified, a more verbose format is used
to provide further detail on the contents of the
packet.
send
recv These options limit the tracing to packets sent or
received. Without these options both sent and received
packets will be traced.
Detail, if specified, must be before send or recv. If a protocol
allows for several different types of packet tracing, modifiers may be
applied to each individual type. But be aware that within one tracing
specification the trace flags are summed up, so specifying detail
packets will turn on full tracing for all packets.
Traceoptions syntax [Toc] [Back]
traceoptions ["trace_file" [replace] [size size[k|m] files files]]
[control_options] trace_options [except trace_options] ;
traceoptions none ;
trace_file
Specifies the file to receive tracing information. If
this file name does not begin with a slash (/), the
directory where gated was started in prepended to the
name.
replace Tracing should start by replacing an existing file. The
default is to append to an existing file.
size size[k|m] files files
Limit the maximum size of the trace file to the
specified size (minimum 10k). When the trace file
reaches the specified size, it is renamed to file.0,
then file.1, file.2 up to the maximum number of files
(minimum specification is 2).
control_options
Specifies options that control the appearance of
tracing. Valid values are:
nostamp
Specifies that a timestamp should not be prepended
Hewlett-Packard Company - 8 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
to all trace lines.
except trace_options
Used to enable a broad class of tracing and then
disable more specific options.
none Specifies that all tracing should be turned off for
this protocol or peer.
Directive Statements [Toc] [Back]
Directive statements provide direction to the GateD configuration
language parser about included files and the directories in which
these files reside. Directive statements are immediately acted upon by
the parser. Other statements terminate with a semi-colon (;), but
directive statements terminate with a newline. The two directive
statements are:
%directory "directory"
Defines the directory where the include files are stored.
When it is used, GateD looks in the directory identified by
pathname for any included files that do not have a fully
qualified filename, such as files that do not begin with
"/". This statement does not actually change the current the
directory, it just specifies the prefix applied to included
file names.
%include "filename"
Identifies an include file. The contents of the file is
included in the gated.conf file at the point in the
gated.conf file where the %include directive is encountered.
If the filename is not fully qualified (does not begin with
"/"), it is considered to be relative to the directory
defined in the %directory directive. The %include directive
statement causes the specified file to be parsed completely
before resuming with this file. Nesting up to ten levels is
supported. The maximum nesting level may be increased by
changing the definition of FI_MAX in parse.h.
In a complex environment, segmenting a large configuration into
smaller more easily understood segments might be helpful, but one of
the great advantages of GateD is that it combines the configuration of
several different routing protocols into a single file. Segmenting a
small file unnecessarily complicates routing configurations.
Options Statements [Toc] [Back]
Options statements allow specification of some global options. If
used, options must appear before any other type of configuration
statement in the gated.conf file.
The options statement syntax is:
Hewlett-Packard Company - 9 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
options
[ nosend ]
[ noresolv ]
[ gendefault [ preference preference ] [ gateway gateway] ]
[ syslog [ upto ] log_level ]
[ mark time ]
;
The options list can contain one or more of the following options:
gendefault [ preference preference ] [ gateway gateway]
When gendefault is enabled, when a BGP or EGP neighbor is up
it causes the creation of a default route with the special
protocol default. This can be disabled per BGP/EGP group
with the nogendefault option. By default, this route has a
preference of 20. This route is normally not installed in
the kernel forwarding table, it is only present so it can be
announced to other protocols. If a gateway is specified, the
default route will be installed in the kernel forwarding
table with a next hop of the listed gateway.
Note that the use of the more general option is preferred to
the use of this gendefault option. The gendefault option may
go away in future releases. The the section on Route
Aggregation for more information on the generate statement.
nosend
Do not send any packets. This option makes it possible to
run GateD on a live network to test protocol interactions
without actually participating in the routing protocols. The
packet traces in the GateD log can be examined to verify
that GateD is functioning properly. This is most useful for
RIP and HELLO and possibly the SMUX SNMP interface. This
option does not yet apply to BGP and is less than useful
with EGP and OSPF.
noresolv
By default GateD will try to resolve symbolic names into IP
addresses by using the gethostbyname() and getnetbyname()
library calls. These calls usually use the Domain Name
System (DNS) instead of the hosts local host and network
tables. If there is insufficient routing information to send
DNS queries, GateD will deadlock during startup. This option
can be used to prevent these calls, symbolic names will
result in configuration file errors.
syslog [ upto ] log_level
Controls the amount of data GateD logs via syslog on systems
where setlogmask() is supported. The available logging
levels and other terminology are as defined in the
setlogmask(3) man page. The default is equivalent to syslog
Hewlett-Packard Company - 10 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
upto info.
mark time
Specifying this option causes gated to output a message to
the trace log at the specified interval. This can be used as
one method of determining if gated is still running.
Interfaces Statement [Toc] [Back]
Interface Syntax
interfaces {
options
[ strictinterfaces ]
[ scaninterval time ]
[ aliases-nh ( primary | lowestip | keepall ) ]
;
interface interface_list
[ preference preference ]
[ down preference preference ]
[ passive ]
[ simplex ]
[ reject ]
[ blackhole ]
[ alias primary address ]
[ aliases-nh ( primary | lowestip | keepall ) ]
;
define address
[ broadcast address ] | [ pointtopoint address ]
[ netmask mask ]
[ multicast ]
;
} ;
An interface is the connection between a router and one of its
attached networks. A physical interface may be specified by interface
name, by IP address, or by domain name, (unless the network is an
unnumbered point-to-point network.) Multiple levels of reference in
the configuration language allow identification of interfaces using
wildcard, interface type name, or delete word address. Be careful with
the use of interface names as future Unix operating systems may allow
more than one address per interface. The interface_list is a list of
one or more interface names including wildcard names (names without a
number) and names which may specify more than one interface or
address, or the token all for all interfaces.
options
Allows configuration of some global options related to
interfaces. These are:
strictinterfaces
Indicates that it is a fatal error to reference an
interface in the configuration file that is not present
Hewlett-Packard Company - 11 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
when GateD is started and not listed in a define
statement. Without this option a warning message will
be issued but GateD will continue.
scaninterval time
Specifies how often GateD scans the kernel interface
list for changes. The default is every 15 seconds on
most systems, and 60 seconds on systems that pass
interface status changes through the routing socket
(BSD 4.4). Note that GateD will also scan the
interface list on receipt of a SIGUSR2.
aliases-nh ( primary | lowestip | keepall )
Specifies which address GateD will install as the next
hop for interface routes when multiple addresses are
assigned to an interface like the Service Guard
environment. If primary is used, the primary interface
address (default) will be installed. If lowestip is
used, the address with the lowest IP address will be
installed. If keepall is used, all interface routes are
kept in the kernel up to a maximum of RT_N_MULTIPATH
routes. This is a compile-time constant. This is a
global parameter that may be overridden for interfaces
using the interface option.
Note: The keepall option is mandatory when gated is
being used in a Service Guard environment.
interface interface_list
Sets interface options on the specified interfaces. An
interface list is all or a list of interface names (see
warning about interface names), domain names, or numeric
addresses. Options available on this statement are:
preference preference
Sets the preference for routes to this interface when
it is up and appears to be functioning properly. The
default preference is 0.
down preference preference
Sets the preference for routes to this interface when
GateD does not believe it to be functioning properly,
but the kernel does not indicate it is down. The
default value is 120.
passive
Prevents GateD from changing the preference of the
route to this interface if it is not believed to be
functioning properly due to lack of received routing
information. GateD will only perform this check if the
interface is actively participating in a routing
Hewlett-Packard Company - 12 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
protocol.
simplex
Defines an interface as unable to hear its own
broadcast packets. Some systems define an interface as
simplex with the IFF_SIMPLEX flag, on others it needs
to be specified in the configuration file. On simplex
interfaces, packets from myself are assumed to have
been looped back in software and are not used as an
indication that the interface is functioning properly.
reject
Specifies that the address of the interface which
matches these criteria will be used as the local
address when installing reject routes in the kernel.
Should only be used with systems based on BSD 4.3 Tahoe
or earlier which have installed a reject/blackhole
pseudo interface.
blackhole
Specifies that the address of the interface which
matches these criteria will be used as the local
address when installing reject routes in the kernel.
Should only be used with systems based on BSD 4.3 Tahoe
or earlier which have installed a reject/blackhole
pseudo interface.
alias primary address
Specifies a primary address for this interface. This
option overrides the address that GateD determines to
be primary.
aliases-nh ( primary | lowestip | keepall )
Specifies which address GateD will install as the next
hop for the route associated with this interface when
multiple addresses are assigned to an interface like
the Service Guard environment. If primary is used, the
primary interface address (default) will be installed.
If lowestip is used, the address with the lowest IP
address will be installed. If keepall is used, all
interface routes are kept in the kernel up to a
maximum of RT_N_MULTIPATH routes. This is a compiletime
constant. This parameter overrides the global
option for this interface.
Note: The keepall option is mandatory when gated is
being used in a Service Guard environment.
define address
Defines interfaces that might not be present when GateD is
started so they may be referenced in the configuration file
Hewlett-Packard Company - 13 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
when strictinterfaces is defined. Possible define keywords
are:
broadcast address
Defines the interface as broadcast capable (Ethernet or
Token Ring) and specifies the broadcast address.
pointtopoint address
Defines the interface as a point-to-point interface
(SLIP or PPP) and specifies the address on the local
side. The first address on the define statement
references the address of the host on the remote end of
the interface, the address specified after this
pointtopoint keyword defines the address on the local
side of the interface.
An interface not defined as broadcast or point-to-point is
assumed to be non-broadcast multiaccess (NBMA), such as an
X.25 network.
netmask mask
Specifies the subnetmask to be used on this interface.
This is ignored on pointtopoint interfaces.
multicast
Specifies that the interface is multicast capable.
Interface lists [Toc] [Back]
An interface list is a list of references to interfaces or groups of
interfaces. There are four methods available for referring to
interfaces. They are listed here from most general to most specific.
all This refers to all available interfaces.
Interface name wildcard
This refers to all the interfaces of the same type. Unix
interfaces consist of the name of the device driver, like
ie, and a unit number, like 0, 5 or 22. Reference to the
name contain only alphabetic characters and match any
interfaces that have the same alphabetic part.
For example, ie on a Sun would refer to all Interlan
Ethernet interfaces, le would refer to all Lance Ethernet
interfaces. But ie would not match iel0.
Interface name
This refers to a specific interface, usually one physical
interface. These are specified as an alphabetic part
followed by a numeric part. This will match one specific
interface. But be aware that on many systems, there can be
more than one protocol (IP) address on a given physical
Hewlett-Packard Company - 14 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
interface. For example, ef1 will match an interface named
ef1, but not an interface named ef10.
Interface address
This matches one specific interface. The reference can be by
protocol address (10.0.0.51), or by symbolic hostname
(nic.ddn.mil). Note that a symbolic hostname reference is
only valid when it resolves to only one address. Use of
symbolic hostnames is not recommended.
If many interface lists are present in the configuration file with
more than one parameter, these parameters are collected at run-time to
create the specific parameter list for a given interface. If the same
parameter is specified on more than one list, the parameters with the
most specific interface is used.
For example, consider a system with three interfaces, le0, le1 and
du0.
rip yes {
interface all noripin noripout ;
interface le ripin ;
interface le1 ripout ;
} ;
RIP packets would only be accepted from interfaces le0 and le1, but
not from du0. RIP packets would only be sent on interface le1.
IP Interface addresses and routes [Toc] [Back]
The BSD 4.3 and later networking implementations allow four types of
interfaces. Some implementations allow multiple protocol addresses per
physical interface, these are mostly based on BSD 4.3 Reno or later.
loopback
This interface must have the address of 127.0.0.1. Packets
sent to this interface are sent back to the originator. This
interface is also used as a catch all interface for
implementing other features, such as reject and blackhole
routes. Although a netmask is reported on this interface, it
is ignored. It is useful to assign an additional address to
this interface that is the same as the OSPF or BGP router
id; this allows routing to a system based on the router id
which will work if some interfaces are down.
broadcast
This is a multi-access interface capable of a physical level
broadcast, such as Ethernet, Token Ring and FDDI. This
interface has an associated subnet mask and broadcast
address. The interface route to an broadcast network will be
a route to the complete subnet.
Hewlett-Packard Company - 15 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
point-to-point
This is a tunnel to another host, usually on some sort of
serial link. This interface has a local address, and a
remote address. Although it may be possible to specify
multiple addresses for a point-to-point interface, there
does not seem to be a useful reason for doing so.
The remote address must be unique among all the interface
addresses on a given router. The local address may be shared
among many point-to-point and up to one non-point-to-point
interface. This is technically a form of the router id
method for addressless links. This technique conserves
subnets as none are required when using this technique.
If a subnet mask is specified on a point-to-point interface,
it is only used by RIP version 1 and HELLO to determine
which subnets may be propagated to the router on the other
side of this interface.
non-broadcast multi-access or nbma
This type of interface is multi-access, but not capable of
broadcast. And example would be frame relay and X.25. This
type of interface has a local address and a subnet mask.
GateD insures that there is a route available to each IP interface
that is configured and up. Normally this this done by the ifconfig
command that configures the interface; GateD does it to insure
consistency.
For point-to-point interfaces, gated installs some special routes. If
the local address on one or more point-to-point interfaces is not
shared with a non-point-to-point interface, gated installs a route to
the local address pointing at the loopback interface with a preference
of 110. This insures that packets originating on this host destined
for this local address are handled locally. OSPF prefers to route
packets for the local interface across the point-to-point link where
they will be returned by the router on the remote end. This is used to
verify operation of the link. Since OSPF installs routes with a
preference of 10, these routes will override the route installed with
a preference of 110.
If the local address of one or more point-to-point interfaces is
shared with a non-point-to-point interface, gated installs a route to
the local with a preference of 0 that will not be installed in the
forwarding table. This is to prevent protocols like OSPF from routing
packets to this address across a serial interface when this system
could be functioning as a host.
When the status of an interface changes, GateD notifies all the
protocols, which take the appropriate action. GateD assumes that
interfaces which are not marked UP do not exist. While this might not
Hewlett-Packard Company - 16 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
be the most correct action, it is the way things currently work.
GateD ignores any interfaces that have invalid data for the local,
remote or broadcast addresses or the subnet mask. Invalid data
includes zeros in any field. GateD will also ignore any point-to-
point interface that has the same local and remote addresses, it
assumes it is in some sort of loopback test mode.
Definition Statements [Toc] [Back]
Definition statements are general configuration statements that relate
to all of GateD or at least to more than one protocol. The three
definition statements are autonomoussystem, routerid and martians. if
used, autonomoussystem, routerid and martians must appear before any
other type of configuration statement in gated.conf file.
Autonomous System configuration [Toc] [Back]
autonomoussystem autonomous_system [ loops number ] ;
Sets the autonomous system number of this router to be autonomous
system. This option is required if BGP or EGP are in use. The AS
number is assigned by the Network Information Center (NIC).
Loops is only for protocols supporting AS paths, such as BGP. It
controls the number of times this autonomous system may appear in an
AS path and defaults to 1 (one).
Router ID configuration [Toc] [Back]
routerid host ;
Sets the router identifier for use by the BGP and OSPF protocols. The
default is the address of the first interface encountered by GateD.
The address of a non-point-to-point interface is preferred over the
local address of a point-to-point interface and an address on a
loopback interface that is not the loopback address (127.0.0.1) is
most preferred.
Martian configuration [Toc] [Back]
martians {
host host [ allow ] ;
network [ allow ] ;
network mask mask [ allow ] ;
network masklen number [ allow ] ;
default [ allow ] ;
} ;
Defines a list of martian addresses about which all routing
information is ignored. Sometimes a misconfigured system sends out
obviously invalid destination addresses. These invalid addresses,
called martians, are rejected by the routing software. This command
allows additions to the list of martian addresses. See the section on
Route Filtering for more information on specifying ranges. Also, the
Hewlett-Packard Company - 17 - HP-UX 11i Version 2: August 2003
gated.conf(4) gated.conf(4)
allow parameter may be specified to explicitly allow a subset of a
range that was disallowed.
Sample Definition Statements [Toc] [Back]
options gendefault ;
autonomoussystem 249 ;
|