rpc_intro(1m) Open Software Foundation rpc_intro(1m)
NAME [Toc] [Back]
rpc_intro - Introduction to DCE RPC daemon and RPC control program
DESCRIPTION [Toc] [Back]
DCE RPC provides two administrative facilities, the RPC daemon and the
RPC control program.
Note: These facilities are superceded by the DCE Host daemon
(dced) and the DCE control program (dcecp) for OSF DCE
+ The RPC daemon is a process that provides the Endpoint Map
Service, which maintains the local endpoint map for local RPC
servers and looks up endpoints for RPC clients. An endpoint is
the address of a specific instance of a server executing in a
particular address space on a given system (a server instance).
Each endpoint can be used on a system by only one server at a
An endpoint map is a database where servers register their
binding information, including endpoints, for each of their RPC
interfaces and the associated RPC objects. Each combination of
binding information, interface identifier, and object UUID uses a
distinct element in the local endoint map.
The rpcd command starts the RPC daemon.
+ The control program provides a set of commands for accessing the
operations of the RPC name service interface (NSI). For managing
endpoint maps, the control program supports showing endpoint map
elements and removing any set of map elements from the local
endpoint map or from any remote endpoint map.
The rpccp command starts the RPC control program (RPCCP).
EXIT VALUES [Toc] [Back]
The RPC control program reports DCE error messages on the command
line. If the command executes successfully, the internal value
returned is 0 (zero); otherwise, the value is -1 (negative one).
RELATED INFORMATION [Toc] [Back]
Commands: dced, dcecp, rpcd(1m), rpccp(1m)
Books: , ,
Hewlett-Packard Company - 1 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96 [ Back ]