passwd_export(1m) OSF passwd_export(1m)
NAME [Toc] [Back]
passwd_export - Creates local password and group files
SYNOPSIS [Toc] [Back]
passwd_export [-d dir_name] [-m max_entries] [-h[elp]] [-n] [-s] [-v]
OPTIONS [Toc] [Back]
The name of the directory to store the password, group, and
organization files created by passwd_export. If you do not
enter a directory name, the files are stored in the /etc
-h[elp] Display help information.
-n Ignore passwd_override and group_override file entries.
Without this option, passwd_export applies the override
entries from both files to the local password and group
files it creates.
The maximum number of entries that can be stored in the
-s Sort the local password and group file entries by UNIX
number. If you do not specify this option, the entries are
in order as they are retrieved from the registry.
-v Run in verbose mode.
-x Do not create entries for users with OMIT as their encrypted
password in the passwd_override and group_override files.
See the passwd_override and group_override reference pages
for further details about omitting users.
DESCRIPTION [Toc] [Back]
The dceshared/bin/passwd_export command creates local password and
group files from registry data. These files are used when the network
registry is unavailable and by programs that use the original UNIX
passwd and group interfaces instead of the DCE interfaces. Use
passwd_export to keep these local files consistent with the registry
When passwd_export runs, it makes backup copies of the current
password and group files, if they exist. The files are named,
respectively, passwd.bak and group.bak.
Hewlett-Packard Company - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_28386-88
passwd_export(1m) Open Software Foundation passwd_export(1m)
By default, the backups are stored and the new files created in the
/etc directory. You can override the default by supplying a directory
name with the -d option.
Running passwd_export [Toc] [Back]
The passwd_export command is commonly run with an entry in
/usr/lib/crontab. For example, to update the files every hour, the
0 * * * * dcesharedbin/passwd_export
In large network environments, it is a good idea to stagger the times
passwd_export is run.
RELATED INFORMATION [Toc] [Back]
Files: group(5), passwd(5), passwd_override(5), group_override(5)
Hewlett-Packard Company - 2 -OSF DCE 1.1/HP DCE 1.8 PHSS_28386-88 [ Back ]