NAME [Toc] [Back]
kcmond - EMS Kernel Tunable Monitor daemon
SYNOPSIS [Toc] [Back]
DESCRIPTION [Toc] [Back]
The kcmond daemon monitors the consumption of kernel resources. It is
an Event Monitoring Services (EMS - see ems(5)) monitor. The data
collected by kcusage can be displayed by kcusage(1M).
kcmond includes a resource dictionary file
(/etc/opt/resmon/dictionary/kcmond_01.dict) which is used by EMS to
identify resources for monitoring.
Users can control the monitoring of each kernel tunable by setting a
percentage value for the consumption of that resource. For example, if
the user sets a value of 75 for nproc, the Kernel Tunable Monitor will
report an event when the number of processes reaches 75% of the nproc
The kcalarm(1M) command is used to add, modify and delete kernel
tunable alarms. The kcusage(1M) command is used to view data collected
by kcmond. The kcweb(1M) command provides a Web-based, graphical user
interface to control alarms and view usage data, including graphs of
the usage data.
kcmond is a light weight daemon that will exit after being idle for
SUPPORTED PARAMETERS [Toc] [Back]
For a complete list of the kernel tunables that can be monitored with
this daemon, see the kcusage(1M) manpage.
DEPENDENCIES [Toc] [Back]
kcmond must be run by the registrar process of the Event Monitoring
Service (EMS) and is not designed to be run from the command line.
AUTHORS [Toc] [Back]
kcmond was developed by Hewlett-Packard.
FILES [Toc] [Back]
The resource dictionary for kcmond,
describes the location (e.g.
/system/kernel_tunables/nproc) of kernel
tunables in the resource hierarchy and
Hewlett-Packard Company - 1 - HP-UX 11i Version 2.0: May 2003
references kcmond as the resource
/etc/opt/resmon/log/api.log Log file for the entire Resource Monitor
Framework, including kcmond. Any errors
are logged here.
SEE ALSO [Toc] [Back]
kcalarm(1M), ems(5), kcusage(1M)
Hewlett-Packard Company - 2 - HP-UX 11i Version 2.0: May 2003 [ Back ]