*nix Documentation Project
·  Home
 +   man pages
·  Linux HOWTOs
·  FreeBSD Tips
·  *niX Forums

  man pages->HP-UX 11i man pages -> dcecp_object (1m)              
Title
Content
Arch
Section
 

Contents


 object(1m)               Open Software Foundation                object(1m)




 NAME    [Toc]    [Back]
      object - A dcecp object that manages an object in CDS

 SYNOPSIS    [Toc]    [Back]
      object create object_name_list [-attribute attribute_list [-single]]

      object delete object_name_list

      object help [operation | -verbose]

      object modify object_name_list
      {-add attribute_list [-single] |
      -remove attribute_list [-types] |
      -change attribute_list}

      object operations

      object show object_name_list [-schema]


 ARGUMENTS    [Toc]    [Back]
      object_name_list
                Examples of objects are remote procedure call (RPC) server
                entries, group entries, profile entries, and so on.

      operation The name of the object operation for which you want to see
                help information.


 DESCRIPTION    [Toc]    [Back]
      An object object represents an entity in CDS that has a name and
      attributes. An object identifies a resource such as a host system, a
      printer, an application, or a file.  Attributes consist of a type and
      one or more values.  Every object is the child of a CDS directory.

 ATTRIBUTES    [Toc]    [Back]
      CDS_Class Specifies the class to which an object belongs.

      CDS_CTS   Specifies the creation timestamp of the CDS object. The
                value is a read-only DTS-style timestamp, which is set by
                the system.

      CDS_ClassVersion    [Toc]    [Back]
                Contains the version number of the object's class, which
                allows applications to build in compatibility with entries
                created by earlier versions.

      CDS_ObjectUUID    [Toc]    [Back]
                Specifies the unique identifier of the object. The read-only
                identifier is set by the system at creation time.




 Hewlett-Packard Company            - 1 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




      CDS_UTS   Specifies the timestamp of the most recent update to an
                attribute of the object. The value is a read-only DTS-style
                timestamp, which is set by the system.


      See the OSF DCE Administration Guide for more information about object
      attributes.

 OPERATIONS    [Toc]    [Back]
    object create
      Creates a new object entry in CDS.  The syntax is as follows:

      object create object_name_list [-attribute attribute_list [-single]]


      Options    [Toc]    [Back]

      -attribute attribute_list
                Allows you to specify attributes by using an attribute list.
                See ATTRIBUTES for more information about object attributes.

      -single   Specifies that attributes are single-valued.


      The create operation creates a new object entry in CDS.  This task is
      usually done through a client application. The required
      object_name_list argument is a list of the full CDS names of the
      object entries to be created.

      Optionally, you can use the -attribute option to associate one or more
      attributes (see ATTRIBUTES) with each object being created.  The
      attribute values are multi-valued unless the -single option is
      specified, in which case all attributes are single-valued.  The
      -single option is valid only if the -attribute option is specified.
      This operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      You must have i (insert) permission to the parent directory.

      Examples    [Toc]    [Back]

      The following command creates an object entry named
      /.:/sales/east/floor1cp:

      dcecp> object create /.:/sales/east/floor1cp -attribute \
      > {{CDS_Class printer} {CDS_ClassVersion 1.0}}
      dcecp>






 Hewlett-Packard Company            - 2 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




    object delete
      Removes an object entry from CDS.  The syntax is as follows:

      object delete object_name_list


      The delete operation removes an object entry from CDS. The required
      object_name_list argument is a list of the full CDS names of the
      object entries to be deleted. This operation returns an empty string
      on success.

      Privileges Required    [Toc]    [Back]

      You must have d (delete) permission to the object entry or A (Admin)
      permission to the directory that stores the object entry.

      Examples    [Toc]    [Back]

      The following command deletes the object entry
      /.:/sales/east/floor1pr2:

      dcecp> object delete /.:/sales/east/floor1pr2
      dcecp>


    object help
      Returns help information about the object object and its operations.
      The syntax is as follows:

      object help [operation | -verbose]


      Options    [Toc]    [Back]

      -verbose  Displays information about the object object.


      Used without an argument or option, the object help command returns
      brief information about each object operation. The optional operation
      argument is the name of an operation about which you want detailed
      information. Alternatively, you can use the -verbose option for more
      detailed information about the object object itself.

      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the object help command.

      Examples    [Toc]    [Back]

      dcecp> object help
      create              Creates the named object.



 Hewlett-Packard Company            - 3 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




      delete              Deletes the named object.
      modify              Adds, removes or changes an attribute in the named object.
      show                Returns the attributes of an object.
      help                Prints a summary of command-line options.
      operations          Returns a list of the valid operations for this command.
      dcecp>


    object modify
      Adds or removes attributes or changes attribute values for object
      entries in CDS.  The syntax is as follows:

      object modify object_name_list
      {-add attribute_list [-single] |
      -remove attribute_list [-types] |
      -change attribute_list}


      Options    [Toc]    [Back]

      -add attribute_list
                Adds one or more new attributes to an object entry.

      -single   May be used with the -add option to specify that attributes
                to be added are single-valued.

      -remove attribute_list
                Eliminates one or more attribute values from an attribute
                type of an object entry.  For instance, removing a value
                from an attribute with three values leaves the attribute
                with two values.  The argument is an attribute list of the
                following form:

                {{attribute value}...{attribute value}}


                To remove an attribute type as well as all its values, use
                the -types option along with the -remove option.

                If an attribute is not present, an error is returned. Fixed
                CDS attribute types, such as the CDS creation timestamp
                (CDS_CTS), cannot be removed.

      -types    May be used with the -remove option to remove the attribute
                type as well as its values.  Invalid without the -remove
                option.

      -change attribute_list
                Changes one attribute value to another for an object entry.
                The existing value of each attribute in attribute_list is
                replaced by the new value given. For multi-valued



 Hewlett-Packard Company            - 4 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




                attributes, all existing values are replaced by all the
                values listed for the attribute in the attribute list.  If
                an attribute or value is not present, an error is returned.


      The modify operation adds or removes attributes, or changes attribute
      values for object entries in CDS.  This task is usually done through a
      client application. The required object_name_list argument is a list
      of the full CDS names of the object entries to be modified.  This
      operation returns an empty string on success.

      Privileges Required    [Toc]    [Back]

      You must have w (write) permission to the object entry.

      Examples    [Toc]    [Back]

      To add the sales_record attribute with a value of region2 to the
      object entry named /.:/Q1_records, follow these steps:


       1.  Read the cds_attributes file to check that the attribute
           sales_record is listed, as shown in the following display:

               OID         LABEL           SYNTAX
           1.3.22.1.3.66   sales_record    char


       2.  Enter the following command to assign the value region2 to the
           attribute sales_record of the object entry named /.:/Q1_records.

           dcecp> object modify /.:/Q1_records -add {sales_record region2}
           dcecp>


      To remove the RPC_CLASS and RPC_CLASS_VERSION  attributes:

      dcecp> object modify /.:/foo -remove {RPC_CLASS RPC_CLASS_VERSION} -types
      dcecp>


    object operations
      Returns a list of the operations supported by the object object. The
      syntax is as follows:

      object operations


      The list of available operations is in alphabetical order except for
      help and operations, which are listed last.




 Hewlett-Packard Company            - 5 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




      Privileges Required    [Toc]    [Back]

      No special privileges are needed to use the object operations command.

      Examples    [Toc]    [Back]

      dcecp> object operations
      create delete modify show help operations
      dcecp>


    object show
      Returns attribute information associated with specified object
      entries.  The syntax is as follows:

      object show object_name_list [-schema]


      Options    [Toc]    [Back]

      -schema   Indicates whether an attribute is single or multi-valued.
                Note that the same attribute can be single-valued on one
                object and multi-valued on another object.


      The show operation displays attribute information associated with
      specified object entries. The required object_name_list argument is a
      list of the full CDS names of the object entries to be examined. If
      more than one object is shown, the attributes of all the objects are
      concatenated into one list.  The order of the returned attributes is
      the lexical order of the object identifiers (OIDs) of each attribute
      for each object.

      The -schema option indicates whether an attribute is single-valued or
      multi-valued.

      Privileges Required    [Toc]    [Back]

      You must have r (read) permission to the object entry.

      Examples    [Toc]    [Back]

      dcecp> object show /.:/obj
      {RPC_ClassVersion
       {0200}
       {0300}}
      {RPC_Group 1234}
      {CDS_CTS 1994-07-01-22:06:54.990-05:00I0.000/00-00-c0-f7-de-56}
      {CDS_UTS 1994-07-01-22:07:37.248-05:00I0.000/00-00-c0-f7-de-56}
      {CDS_Class 0200}
      dcecp>



 Hewlett-Packard Company            - 6 OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96






 object(1m)               Open Software Foundation                object(1m)




      dcecp> object show /.:/obj -schema
      {RPC_ClassVersion multi}
      {RPC_Group multi}
      {CDS_CTS single}
      {CDS_UTS single}
      {CDS_Class single}
      dcecp>


 RELATED INFORMATION    [Toc]    [Back]
      Commands: dcecp(1m), dcecp_clearinghouse(1m), dcecp_directory(1m),
      dcecp_link(1m).


 Hewlett-Packard Company            - 7 -OSF DCE 1.1/HP DCE 1.8 PHSS_26394-96
[ Back ]
 Similar pages
Name OS Title
dcecp_directory HP-UX A dcecp object that manages a CDS directory
dcecp_clearinghouse HP-UX A dcecp object that manages a clearinghouse in CDS
dcecp_rpcentry HP-UX A dcecp object that manages an RPC entry in CDS
dcecp_server HP-UX A dcecp object that manages DCE application servers
dcecp_dts HP-UX A dcecp object that manages a dtsd process
dcecp_rpcgroup HP-UX A dcecp object that manages an RPC group entry in CDS
dcecp_cdscache HP-UX A dcecp object that manages a local CDS cache
dcecp_rpcprofile HP-UX A dcecp object that manages an RPC profile entry in CDS
dcecp_link HP-UX A dcecp object that manages a soft link in CDS
dcecp_acl HP-UX A dcecp object that manages DCE access control lists
Copyright © 2004-2005 DeniX Solutions SRL
newsletter delivery service