NAME [Toc] [Back]
setmnt - establish the file-system mount table, /etc/mnttab
SYNOPSIS [Toc] [Back]
DESCRIPTION [Toc] [Back]
The setmnt command creates the /etc/mnttab table (see mnttab(4)),
which is needed by both the mount and umount commands (see mount(1M)).
setmnt reads the standard input and creates an entry in /etc/mnttab
for each line of input. Input lines have the format:
where filesys is the name of the device special file associated with
the file system (such as /dev/dsk/c0t5d0) and node is the root name of
that file system. Thus filesys and node become the first two strings
in the mount table entry.
WARNINGS [Toc] [Back]
The mount and umount commands rewrite the /etc/mnttab file whenever a
file system is mounted or unmounted if /etc/mnttab is found to be out
of date with the mounted file system table maintained internally by
the HP-UX kernel. The syncer command also updates /etc/mnttab if it
is out of date (see syncer(1M)).
/etc/mnttab should never be manually edited. Use of this command to
write invalid information into /etc/mnttab is strongly discouraged.
The setmnt command is not intented to be run interactively; input
should be directed to it from a file (for example, setmnt <
/tmp/file.mnt). If run interactively, terminate input with a ctrl-D.
setmnt silently enforces an upper limit on the maximum number of
It is unwise to use setmnt to create false entries for mount and
This command is obsolete and it may not be available for future
FILES [Toc] [Back]
/etc/mnttab Mounted file system table
SEE ALSO [Toc] [Back]
devnm(1M), mount(1M), syncer(1M), mnttab(4).
STANDARDS CONFORMANCE [Toc] [Back]
setmnt: SVID2, SVID3
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003 [ Back ]