mount_vxfs(1M) mount_vxfs(1M)
NAME [Toc] [Back]
mount_vxfs: mount, umount - mount and unmount VxFS file systems
SYNOPSIS [Toc] [Back]
mount [-l] [-v|-p]
mount [-F vxfs] [-eQ] -a
mount [-F vxfs] [-eQrV] [-o specific_options] {special|directory}
mount [-F vxfs] [-eQrV] [-o specific_options] special directory
umount [-V] [-v] {special|directory}
umount [-F vxfs] [-v] -a
DESCRIPTION [Toc] [Back]
mount attaches special, a removable file system, to directory, a
directory on the file tree. (This directory is also known as the
mount point). directory, which must already exist, becomes the name
of the root of the newly mounted file system. If you omit either
special or directory, mount attempts to determine the missing value
from an entry in /etc/fstab. mount can be invoked on any removable
file system, except /. special and directory must be given as
absolute path names.
mount notifies the system that special, a VxFS block special device,
is available to users from mount_point, which must exist before mount
is invoked. mount_point becomes the name of the root of the newly
mounted file system special.
Large files (over two gigabytes) are supported on HP-UX 10.20 systems
and above.
Unlike some file system commands, you cannot specify multiple -o
options to mount; only the last option is used.
If you invoke mount with no arguments, it lists all the mounted file
systems from the mounted file system table, /etc/mnttab.
The umount command unmounts mounted file systems.
The vxumount command provides a force option to unmount mounted file
systems.
Only the superuser can mount and umount file systems. Other users can
use mount to list mounted file systems.
Options [Toc] [Back]
mount recognizes the following options:
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
-a Attempts to mount all file systems described in
/etc/fstab. All optional fields in /etc/fstab must be
included and supported. If -F vxfs is specified, all
VxFS file systems in /etc/fstab are mounted. If noauto
is specified in an entry's option list (in /etc/fstab),
that entry is skipped (not mounted). File systems are
not necessarily mounted in the order listed in
/etc/fstab.
-e Verbose mode. Writes a message to the standard output
indicating which file system is being mounted.
-F vxfs Specifies the file system type (vxfs).
-l Limits actions to local file systems only.
-o specific options
Specifies options specific to the VxFS file system type.
See the "Specific -o Options" topic in this section..
-p Reports the list of mounted file systems in /etc/fstab
format.
-Q Prevents display of error messages, resulting from an
attempt to mount already mounted file systems.
-r Mounts the specified file system as read-only. Physically
write-protected file systems must be mounted in this way
or errors occur when access times are updated, whether or
not any explicit write is attempted.
-v Reports the regular output with file system type and
flags, however, directory and special fields are
reversed.
-V Echos the completed command line, but does not execute
the command. The command line is generated by
incorporating the user-specified options and other
information derived from /etc/fstab. This option allows
the user to verify the command line.
umount recognizes the following options:
-a Attempt to unmount all file systems described in
/etc/mnttab. All optional fields in /etc/mnttab must be
included and supported. If -F vxfs is specified, all VxFS
file systems in /etc/mnttab are unmounted. File systems
are not necessarily unmounted in the order listed in
/etc/mnttab.
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
-F vxfs Specify the file system type (vxfs).
-v Verbose mode. Write a message to the standard output
indicating which file system is being unmounted.
-V Echo the completed command line, but do not execute the
command. The command line is generated by incorporating
the user-specified options and other information derived
from /etc/fstab. This option allows the user to verify
the command line.
Operands [Toc] [Back]
mount recognizes the following operands:
special Name of a VxFS block special device, a removable file
system.
mount_point
Name of an existing directory from which the mounted file
system is available.
Specific -o Options [Toc] [Back]
mount supports a set of options specific to the VxFS file system type
through the -o option. specific_options is a list of comma separated
suboptions and/or keyword/attribute pairs intended for the VxFSspecific
module of the command. Unlike some file system commands,
multiple -o options do not accumulate; only the last option is used.
The following specific_options are valid on a VxFS file system:
blkclear
Clears all data extents before allocating them to a file
(requires synchronous zeroing, on disk, of certain newly
allocated extents). This prevents uninitialized data
from being written to a file at the time of a system
crash.
ckpt=ckpt_name
Mounts the Storage Checkpoint of a VxFS file system.
ckpt_name is the name of a file system Storage Checkpoint
previously created. mount_point is the directory on
which to mount the Storage Checkpoint. special is the
Storage Checkpoint pseudo device. Storage Checkpoints
are mounted on pseudo devices that do not appear in the
system name space. The pseudo devices are created and
exist only while the Storage Checkpoint is mounted. A
Storage Checkpoint pseudo device name has the following
format:
device_path:ckpt_name
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
Storage Checkpoints are mounted read-only by default, but
you can mount or remount them as writable using the rw
option. A file system must be mounted before any of its
Storage Checkpoints can be mounted. A file system can be
unmounted only after all of its Storage Checkpoints are
unmounted.
To mount a Storage Checkpoint in shared mode on a cluster
file system, you must also specify the -o cluster option
(see the EXAMPLES Section).
cluster Mounts a file system in shared mode. special must be a
shared volume in a cluster Volume Manager (CVM)
environment. Other nodes in the cluster can also mount
special in shared mode. A local mount cannot be
remounted in shared mode and shared mount cannot be
remounted in local mode.
The first node to mount special is called the primary
node. The primary node handles intent logging for the
cluster. Other nodes are called secondary nodes. A
secondary writable node (rw) is not allowed if the
primary node is mounted as read-only (ro).
convosync=direct|dsync|unbuffered|closesync|delay
Alters the caching behavior of the file system for O_SYNC
and O_DSYNC I/O operations.
The direct value handles any reads or writes with the
O_SYNC or O_DSYNC flag as if the VX_DIRECT caching
advisory is set.
The dsync value handles any writes with the O_SYNC flag
as if the VX_DSYNC caching advisory is set. It does not
modify behavior for writes with O_DSYNC set.
The unbuffered value handles any reads or writes with the
O_SYNC or O_DSYNC flag as if the VX_UNBUFFERED caching
advisory is set.
The closesync value delays O_SYNC or O_DSYNC writes so
that they do not take effect immediately.
The closesync, dsync, direct, and unbuffered values all
run the equivalent of an fsync(2) to be run when any file
accessed with the O_SYNC or O_DSYNC flag is closed.
The delay value delays O_SYNC or O_DSYNC writes so that
they do not take effect immediately. With this option,
VxFS changes O_SYNC or O_DSYNC writes into delayed
writes. No special action is performed when closing a
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
file. This option effectively cancels data integrity
guarantees normally provided by opening a file with
O_SYNC or O_DSYNC.
Note: The convosync option is available only with the HP
OnLineJFS product.
crw The cluster read-write option allows asymmetric mounts,
that is, you can mount a specified cluster file system in
read-only or read-write mode independently of the other
shared file system nodes. crw must be specified with the
-o cluster option. Without specifying crw, the default
functionality of the cluster mount is retained; the
read-write capability of cluster secondaries are the same
as the cluster primary. You can use the crw in
conjunction with rw or ro as shown in the following mount
compatibility matrix:
Secondary [Toc] [Back]
------- ----------------------------------
Primary ro rw ro,crw rw,crw
------- ----------------------------------
ro yes no no no
rw no yes yes yes
ro,crw no yes yes yes
rw,crw no yes yes yes
If the primary is mounted with ro,crw, or rw,crw as shown
in the first column, the secondary read and write
capabilities can still be set independently. For a
cluster mount, rw on the primary enables cluster-wide
read-write capability.
The read and write capabilities can be changed from its
original setting to another using the -o remount option.
The read and write capabilities can be changed according
to the following matrix:
------- ----------------------------------
From/To ro rw ro,crw rw,crw
------- ----------------------------------
ro no yes yes yes
rw no yes no yes
ro,crw no yes yes yes
rw,crw no yes no yes
If a cluster file system is mounted read-write (rw), the
underlying disk group must have the activation mode
attribute set to sharedwrite (sw).
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
If a cluster file system is mounted ro,crw, and the disk
group activation mode is sharedread (sr), that cluster
file system can never be a primary, and must be mounted
seconly (see the seconly option in this section). See
the VERITAS SANPoint Foundation Suite Installation and
Configuration Guide
datainlog|nodatainlog
Generally, VxFS does O_SYNC or O_DSYNC writes by logging
the data and the time change to the inode (datainlog).
If the nodatainlog option is used, the logging of
synchronous writes is disabled; O_SYNC writes the data
into the file and updates the inode synchronously before
returning to the user.
Note: The datainlog option is available only with the HP
OnLineJFS product.
ioerror=disable|nodisable|wdisable|mwdisable
Sets the policy for handling I/O errors on a mounted file
system. Multiple error policies were implemented in VxFS
to handle evolving storage technologies for which a
single approach is no longer adequate.
I/O errors can occur while reading or writing file data,
or while reading or writing metadata. The file system
can respond to these I/O errors either by halting or by
gradually degrading. ioerror provides four policies that
determine how the file system responds to the various
errors. All four policies limit data corruption, either
by stopping the file system or by marking a corrupted
inode as bad.
The following matrix shows how the file system responds
to the various errors depending on the policy set:
file file metadata metadata
read write read write
----------------------------------------
disable | disable | disable | disable | disable |
----------------------------------------
nodisable | degrade | degrade | degrade | degrade |
----------------------------------------
wdisable | degrade | disable | degrade | disable |
----------------------------------------
mwdisable | degrade | degrade | degrade | disable |
----------------------------------------
If disable is selected, VxFS disables the file system
after detecting any I/O error. You must then unmount the
file system and correct the condition causing the I/O
Hewlett-Packard Company - 6 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
error. After the problem is repaired, run fsck and mount
the file system again. In most cases, replay fsck is
sufficient to repair the file system. A full fsck is
required only in cases of structural damage to the file
system's metadata. Select disable in environments where
the underlying storage is redundant, such as RAID-5 or
mirrored disks.
If nodisable is selected, when VxFS detects an I/O error,
it takes steps (sets the appropriate error flags), to
contain the error, but continues running. Note that the
"degraded" condition indicates possible data or metadata
corruption, not the overall performance of the file
system.
For file data read and write errors, VxFS sets the
VX_DATAIOERR flag in the superblock. For metadata read
errors, VxFS sets the VX_FULLFSCK flag in the superblock.
For metadata write errors, VxFS sets the VX_FULLFSCK and
VX_METAIOERR flags in the superblock and may mark
associated metadata as bad on disk. VxFS then prints the
appropriate error messages to the console (see the
VERITAS File System Administrator''s Guide for
information on what actions to take for specific errors).
You should stop the file system as soon as possible and
repair the condition causing the I/O error. After the
problem is repaired, run fsck and mount the file system
again.
Select nodisable if you want to implement the policy that
most closely resembles the previous VxFS error handling
policy.
If wdisable (write disable) or mwdisable (metadata-write
disable) is selected, the file system is disabled or
degraded, as shown in the matrix, depending on the type
of error encountered. Select wdisable or mwdisable for
environments where read errors are more likely to persist
than write errors, such as when using non-redundant
storage. mwdisable is the default ioerror mount option
for local mounts. disable is the default ioerror mount
option for cluster mounts.
Note: If there is serious damage to the file system, or
there is structural corruption of file system metadata,
VxFS marks the file system for full fsck regardless of
which I/O error policy is in effect.
Behavior on cluster file systems is somewhat different.
If the policy selected is disable, the file system is
Hewlett-Packard Company - 7 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
disabled only on the node where the I/O error occurs.
The file system is still accessible from the other nodes.
If the I/O error is on the CFS primary, a new primary is
elected from the remaining nodes and the original primary
becomes a secondary.
disable is the recommended policy for cluster file
systems. With any other policy, a metadata I/O error can
mark the file system for a full file system check. If
the CFS primary subsequently fails, the other nodes in
the cluster cannot take over the primaryship, thereby
disabling access to the file system from all nodes in the
cluster.
Note: If the CVM disk detach policy (the way unusable
disks in a shared disk group are detached) is local, the
I/O error policy must be disable.
largefiles|nolargefiles
These options do not turn largefiles capability on and
off (use mkfs_vxfs or fsadm_vxfs to set and clear the
largefiles flag), but they do verify whether a file
system is largefiles capable. If nolargefiles is
specified and the mount succeeds, then the file system
does not contain any files whose size is two gigabytes or
larger, and such files cannot be created. If largefiles
is specified and the mount succeeds, then the file system
may contain files whose size is two gigabytes or larger,
and large files can be created. For a mount to succeed,
the option must match the largefiles flag as specified by
mkfs_vxfs or fsadm_vxfs.
Note: Large files are supported on HP-UX 10.20 systems
and above. Be careful when enabling large file system
capability. System administration utilities such as
backup may experience problems if they are not large-file
aware.
logiosize=1024|2048|4096
Control size of intent log I/O buffers. Default value is
determined dynamically at mount time. The performance of
some storage devices (specifically, devices using the
read-modify-write feature) improves if the writes are
issued in one or more multiples of a particular size.
When a file system is mounted with the logiosize option,
VxFS writes the intent log in at least size bytes, or a
multiple of size bytes, to obtain the maximum performance
from such devices. The values for size can be 1024,
2048, or 4096.
Hewlett-Packard Company - 8 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
log|delaylog|tmplog|nolog
Control intent logging. To maintain file system
integrity after a system failure, logging must be
enabled. In log mode, file system structural changes are
logged to disk before the system call returns to the
application. If the system crashes, fsck_vxfs(1M)
completes logged operations that did not complete.
In delaylog mode, some system calls return before the
intent log is written. The default is delaylog. This
improves the performance of the system, but some changes
are not guaranteed until a short time later when the
intent log is written. This mode approximates
traditional UNIX system guarantees for correctness in
case of system failures.
In tmplog mode, the intent log is almost always delayed.
This improves performance, but recent changes may
disappear if the system crashes. This mode is only
recommended for temporary file systems.
nolog is an alias for tmplog.
mincache=direct|dsync|unbuffered|closesync|tmpcache
Alter the caching behavior of the file system.
The direct value handles any reads without the O_SYNC
flag, or any writes without the O_SYNC flag, VX_DSYNC,
VX_DIRECT, and VX_UNBUFFERED caching advisories, as if
the VX_DIRECT caching advisory was set.
The dsync value handles any writes without the O_SYNC
flag or one of the VX_DIRECT, VX_DSYNC, or VX_UNBUFFERED
caching advisories as if the VX_DSYNC caching advisory
was set.
The unbuffered value handles any reads without the O_SYNC
flag, or any writes without the O_SYNC flag, VX_DSYNC,
VX_DIRECT, and VX_UNBUFFERED caching advisories, as if
the VX_UNBUFFERED caching advisory was set.
The closesync, dsync, unbuffered, and direct values all
cause the equivalent of an fsync(2) to be run when the
file is closed.
The tmpcache value disables delayed extending writes,
trading off integrity for performance. When this option
is chosen, VxFS does not zero out new extents allocated
as files are sequentially written. Uninitialized data
may appear in files being written at the time of a system
crash. See vxfsio(7) for an explanation of VX_DIRECT,
Hewlett-Packard Company - 9 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
VX_DSYNC, and VX_UNBUFFERED.
Note: mincache=direct, mincache=dsync,
mincache=unbuffered, and mincache=tmpcache are available
only with the HP OnLineJFS product.
noatime Directs the file system to ignore file access time
updates except when they coincide with updates to ctime
or mtime (see the stat(2)) manual page. By default, the
file system is mounted with access time (atime)
recording. You can use the noatime option to reduce disk
activity on file systems where access times are not
important.
qio|noqio
Enables or disables the VERITAS Quick I/O for Databases
option for the given file system. Quick I/O is available
as a licensed feature of VxFS. By default, mount enables
Quick I/O on the file system. If Quick I/O is not
available, mount mounts the file system without Quick
I/O. If qio is specified, but the feature is not
licensed, mount prints an error message and terminates
without mounting the file system. If noqio is specified,
mount disables Quick I/O even if the license is
installed.
For cluster file systems, qio is also the default if a
Quick I/O license is present.
qlog[=special]
Enables the file system to use VERITAS QuickLog.
QuickLog threads multiple file system logs together and
redirects the file system log writes to the special
device. If special is not specified, the file system
selects one of the QuickLog special devices. This option
improves the performance of NFS servers. QuickLog is
available only through other VERITAS products. See the
VERITAS File System Release Notes for current product
information.
quota Enable disk quotas (valid only for rw type file systems).
VxFS maintains quota information in a private area of the
file system. If the file system is mounted with quotas
enabled, and the file system was previously mounted with
quotas disabled and was modified, then the quota
information is rebuilt. This may take a while.
remount Change the mount options for a mounted file system. In
particular, remount changes the logging and caching
policies. It also changes a files system from read-only
to read/write.
Hewlett-Packard Company - 10 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
remount cannot change a file system from read/write to
read-only, nor can it set the snapof or snapsize
attributes.
remount does not check possible changes in /etc/fstab.
If you use any specific option, you must explicitly pass
it in the command line.
rw|ro Read/write or read-only. The default is rw.
seconly Mounts a shared file system as a secondary only. A
secondary-only file system cannot assume the primaryship
for the specified shared file system. For a mount with
the seconly option to succeed, primary must already be
mounted. seconly must be specified with the -o cluster
option. The seconly option overrides any policy that was
set using the fsclustadm command. This option can be set
or reset using the -o remount option. A remount with
seconly fails if the file system node is already the
primary for the file system.
snapof=filesystem
Mount the file system as a snapshot of filesystem, where
filesystem is either the directory on which a VxFS file
system is mounted, or is the block special file
containing a mounted VxFS file system. An explicit -F
vxfs option is required to mount a snapshot file system.
Note: snapof=filesystem is available only with the HP
OnLineJFS product.
snapsize=size
Used in conjunction with snapof. size is the size in
sectors of the snapshot file system being mounted. This
option is required only when the device driver is
incapable of determining the size of special, and
defaults to the entire device if not specified.
Note: snapsize=size is available only with the HP
OnLineJFS product.
suid|nosuid
setuid execution allowed or setuid execution not allowed.
The default is suid.
tranflush
When VxFS is the default boot file system (/stand) on
HP-UX, there can be no intent log replay during the
initial stages of the boot process. To ensure data and
metadata consistency during the boot process, the
tranflush option flushes all metadata updates to disk
Hewlett-Packard Company - 11 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
before returning from a system call. The tranflush
option therefore enables VxFS to approximate the behavior
of a file system with no intent logging functionality.
The tranflush option automatically enables the blkclear
and log options. It is advisable to specify the
mincache=dsync mount option with tranflush. tranflush
must be explicitly specified when remounting the file
system.
The tmplog, delaylog, and datainlog mount options do not
operate with tranflush. The tranflush option does not
operate on read-only file systems or cluster file
systems.
EXAMPLES [Toc] [Back]
List the file systems currently mounted:
mount
Mount a VxFS file system /dev/dsk/c1t2d0 at directory /home
mount -F vxfs /dev/dsk/c1t2d0 /home
Unmount the same file system:
umount /dev/dsk/c1t2d0
To unmount a file system, unmount the Storage Checkpoint first:
umount /ckptdir
umount /fsdir
Mount a Storage Checkpoint of a cluster file system on a VERITAS
Volume Manager volume:
mount -F vxfs -o cluster,ckpt=ckpt_name \
/dev/vx/dsk/dg_name/volume_name:ckpt_name /ckpt_mount_point
Automatically mount Storage Checkpoints when the system reboots. You
can list them in the /etc/fstab file as in the following example:
/dev/vx/dsk/fsvol /fsdir vxfs defaults 0 2
/dev/vx/dsk/fsvol:myckpt /ckptdir vxfs ckpt=myckpt 0 0
FILES [Toc] [Back]
/etc/fstab Static information about the file systems
/etc/mnttab Mounted file system table
SEE ALSO [Toc] [Back]
edquota(1M), fsadm_vxfs(1M), fsck_vxfs(1M), mkfs_vxfs(1M), mount(1M),
vxumount(1M), fsync(2), mount(2), setuid(2), stat(2), fstab(4),
Hewlett-Packard Company - 12 - HP-UX 11i Version 2: August 2003
mount_vxfs(1M) mount_vxfs(1M)
mnttab(4), fs_vxfs(4), quota(5), vxfsio(7).
VERITAS File System Administrator's Guide
VERITAS File System Release Notes
VERITAS SANPoint Foundation Suite Installation and Configuration Guide
STANDARDS CONFORMANCE [Toc] [Back]
mount: SVID3
umount: SVID3
Hewlett-Packard Company - 13 - HP-UX 11i Version 2: August 2003 [ Back ] |