NAME [Toc] [Back]
iCOD - instant Capacity on Demand software for HP-UX
DESCRIPTION [Toc] [Back]
iCOD provides services for instantly increasing or decreasing
processing capacity (CPUs, cells, and memory) on supported HP servers
to meet varying system demands. When the processing demand
significantly changes, you can execute the icod_modify command (see
icod_modify(1M)) to instantly activate or deactivate processors, or
defer an activation or deactivation until the next reboot. The
icod_modify command can also be used to apply codewords and make iCOD
components available for activation. For detailed information about
iCOD, see the iCOD User's Guide located at
Initializing an iCOD Server [Toc] [Back]
iCOD is installed by HP manufacturing on instantly ignited systems or
can be installed by an HP support representative on existing supported
servers as an add-on. iCOD attempts to connect to HP via e-mail for
purposes of asset reporting.
To initialize an iCOD server:
1) Execute the icod_modify -c command to configure contact
information (e-mail address).
2) Execute the icod_stat command (see icod_stat(1M)) to check the
current status of the iCOD processors and verify that the contact
information is set properly.
3) Execute the icod_notify command (see icod_notify(1M)) to send an
asset report to HP, root, and to the specified e-mail address. HP
will respond to the asset report by sending a confirmation e-mail
to the specified e-mail address. Receipt of the confirmation email
verifies that e-mail communication with HP is established.
Codewords [Toc] [Back]
Prior to activating iCOD components, a Right-to-Use (RTU) codeword
must be applied to the system. After an enablement fee has been paid
to HP for every iCOD component that is to be activated, RTU codewords
are available through the HP iCOD portal
Codewords are applied to the system using the icod_modify command.
After an RTU codeword has been applied to the system, the iCOD
component can be activated by using the icod_modify command (if
activating processors), or other commands including parmodify (see
parmodify(1M)) and parmgr (see parmgr(1M)), depending on the type of
Hewlett-Packard Company - 1 - iCOD version B.06.01: March 2004
Software Removal [Toc] [Back]
The iCOD software cannot be removed because other software products
depend on iCOD software to approve configuration changes to the
Contractual Status Of iCOD Processors [Toc] [Back]
Information about the iCOD components (inactive processors, cells, and
memory for which an enablement fee has not been paid) on a system can
be obtained by executing the icod_stat command. This command also
provides information about the amount of temporary capacity presently
in use, and the projected expiration of the temporary capacity.
Virtual Partitions [Toc] [Back]
iCOD processors may be present in systems or partitions where virtual
partition technology is employed. In a virtual partition environment,
processors that are not assigned to any virtual partition are
considered inactive (in addition to other classes of inactive
processors). Unassigned processors can be assigned by either the
icod_modify command or the vparmodify command (see vparmodify(1M)).
Assignment via the vparmodify command does not result in logging of
the activation, e-mail configuration change notification, or
transmission of an asset report to HP (although the daily asset report
will contain this information). HP recommends using the icod_modify
command when activating or deactivating processors in a virtual
partition when iCOD processors are present.
See vparmodify(1M) for more information on virtual partitions.
Processor Sets [Toc] [Back]
In an environment where processor sets are being used, the icod_modify
command activates iCOD processors into the default processor set and
deactivates processors from only the default processor set.
Activation or deactivation of processors in non-default processor sets
is a two step operation, where the first step involves the user
migrating the processors into or out of the default processor set, and
the second step is the activation or deactivation of those processors
using the icod_modify command.
See psrset(1M) for more information on processors sets.
TiCOD (Temporary Capacity) Program [Toc] [Back]
Customers may purchase an amount of temporary capacity time. This
temporary capacity allows one or more iCOD processor to be activated
for up to the specified period of processor minutes, without requiring
the payment of an enablement fee (to HP for the permanent activation
of the processor).
Temporary capacity can be added to the system by applying a temporary
capacity codeword (available from the HP iCOD portal) using the
icod_modify command. Information about the amount of temporary
capacity time remaining on a system can be obtained by executing the
Hewlett-Packard Company - 2 - iCOD version B.06.01: March 2004
iCOD Cell Board
iCOD Cell Board offers a way to have additional (inactive) cell board
capacity in your iCOD system. These iCOD cell boards, which contain
memory and processors, can be activated after a cell RTU codeword is
obtained from the HP iCOD portal and is applied to the system using
the icod_modify command.
SEE ALSO [Toc] [Back]
icod_modify(1M), icod_notify(1M), icod_stat(1M), icodd(1M).
Hewlett-Packard Company - 3 - iCOD version B.06.01: March 2004 [ Back ]