NAME [Toc] [Back]
pfs_exportfs - export and unexport directories to PFS clients
SYNOPSIS [Toc] [Back]
/usr/sbin/pfs_exportfs [ -a -u -v ] [ pathname ]
DESCRIPTION [Toc] [Back]
pfs_exportfs makes a local directory or filename available for
mounting over the network by PFS clients. It is recommended that a
command to invoke pfs_exportfs at boot time be added to rc(1M).
pfs_exportfs uses information contained in the /etc/pfs_exports file
to export pathname (which must be specified as a full pathname). The
superuser can run pfs_exportfs at any time to alter the list or
characteristics of exported directories and filenames. Directories
and files that are currently exported are listed in the file
With no options or arguments, pfs_exportfs prints out the list of
directories and filenames currently exported.
Options [Toc] [Back]
-a All. Export all pathnames listed in /etc/pfs_exports, or if -u
is specified, unexport all of the currently exported pathnames.
-u Unexport the indicated pathnames.
-v Verbose. Print each directory or filename as it is exported or
WARNINGS [Toc] [Back]
PFS is obsolete and no longer supported on any HP-UX release.
Delivery of PFS interfaces will be discontinued in the next HP-UX
PFS, from Young Minds, Inc. (now defunct), was originally adopted by
HP to provide accessibility to Rock Ridge Interchange file system
format on CD-ROM file systems. The equivalent functionality is now
provided via the HP-UX CDFS file system type and HP-UX's standard file
PFS has known functionality and performance problems. HP customers
are urged to stop using the PFS interfaces, including this interface,
pfs_exportfs. Customers should move to accessing all CD-ROM file
system formats by using the standard HP-UX commands, specifying the
file system type as cdfs. For example, to mount a CD-ROM file system,
mount -F cdfs /dev/dsk/c0t0d4 /cdrom
There is no need to treat the cdfs file system type differently from
any other file system type, therefore no special daemons or commands
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
are required to access the variety of CD-ROM file system formats.
See mount(1M) and mount_cdfs(1M).
AUTHOR [Toc] [Back]
psf_exportfs was developed by Young Minds, Inc.
FILES [Toc] [Back]
/etc/pfs_exports static export information
/etc/pfs_xtab current state of exported pathnames
SEE ALSO [Toc] [Back]
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004 [ Back ]