NAME [Toc] [Back]
automountd - autofs mount/unmount daemon
SYNOPSIS [Toc] [Back]
automountd[-TvnL] [-D name=value]
DESCRIPTION [Toc] [Back]
automountd is an RPC server that answers file system mount and unmount
requests from the autofs filesystem. It uses local files or name
service maps to locate filesystems to be mounted. These maps are
described with the automount command (see automount(1M)).
The automountd daemon is automatically invoked if the AUTOFS variable
is set to 1 in /etc/rc.config.d/nfsconf.
Options [Toc] [Back]
-T Trace. Expand each RPC call and display it to
-v Verbose. Log status messages to
-n Turn off browsing for all autofs mount points. This
option overrides the -browse autofs map option on
the local host.
-L Force all mounts to the local host to be NFS mounts
instead of the default LOFS mounts. This is
necessary for highly available NFS mounts.
-D name=value Assign value to the indicated automount map
substitution variable. These assignments cannot be
used to substitute variables in the master map
Tracing [Toc] [Back]
While automountd is running, the signal SIGUSR2 can be sent to
automountd to turn tracing on. It logs messages in
/var/adm/automount.log. To turn tracing off, send the signal SIGUSR2
RETURN VALUE [Toc] [Back]
EXAMPLES [Toc] [Back]
To turn on tracing, enter:
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
No messages are displayed by the trace. Check the results in
WARNINGS [Toc] [Back]
Any filesystems that are being managed by autofs should never be
manually mounted or unmounted. Even if the mount or unmount operation
appears to complete successfully, the resulting change of state to the
autofs managed filesystem can lead to disruptive or unpredictable
results, including but not limited to: commands hanging or not
returning expected results, and applications failing due to their
dependencies on those mounted filesystems. A reboot may be necessary
to resolve these issues.
AUTHOR [Toc] [Back]
automountd was developed by Sun Microsystems, Inc.
FILES [Toc] [Back]
/etc/auto_master master map for automounter
/var/adm/automount.log log file for automountd
/usr/sbin/automountd autofs daemon
SEE ALSO [Toc] [Back]
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003 [ Back ]