NAME [Toc] [Back]
pfs_fstab, mtab - static file system mounting table, mounted file
SYNOPSIS [Toc] [Back]
DESCRIPTION [Toc] [Back]
The /etc/pfs_fstab file contains entries for CD-ROM file systems and
disc images to mount using the pfs_mount(1M) command, which is
normally invoked by rc(1M) script at boot time. This file is used by
various utilities such as pfs_mount and pfs_umount.
The /etc/mtab file contains entries for file systems currently
mounted, and is read by programs using the routines described in
getmntent(3X). umount (see mount(1M)) removes entries from this file.
Each entry consists of a line of the form:
filesystem directory type options freq pass
filesystem is the pathname of a raw or block-special device, the name
of a remote file system in host:pathname form, or the name
of a file created with MakeDisc.
directory is the pathname of the directory on which to mount the
type is the file system type, which can be one of:
pfs-iso9660 to mount a device as iso9660.
pfs-hsfs to mount a device as hsfs.
pfs-rrip to mount a device as rrip.
pfs-nfs to mount an exported PFS file system
options contains a comma-separated list (no spaces) of mounting
options, some of which can be applied to all types of file
systems, and others which only apply to specific types.
options valid on all file systems:
ro Even if not specified, this option is
suid|nosuid Setuid execution allowed or disallowed.
bg|fg If the first attempt fails, retry in
the background, or, in the foreground.
retry=n The number of times to retry the mount
rsize=n Set the read buffer size to n bytes.
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
timeo=n Set the PFS timeout to n tenths of a
retrans=n The number of PFS retransmissions.
soft|hard Return an error if the server does not
respond, or continue the retry request
until the server responds.
intr Allow keyboard interrupts on hard
options specific to iso9660 and hsfs file systems:
xlat=xlat_flags xlat_flags is a colon (:) separated
list of translation options.
Currently supported are no_version,
dot_version, lower_case, and unix.
freq is the interval (in days) between dumps. For a PFS file
system, this should be 0.
pass is the fsck(1M) pass in which to check the partition. For
a PFS file system, this should be 0.
A pound-sign (#) as the first character indicates a comment line which
is ignored by routines that read this file. The order of records in
/etc/pfs_fstab is important because fsck, mount, and umount process
the file sequentially; an entry for a file system must appear after
the entry for any file system it is to be mounted on top of.
EXAMPLES [Toc] [Back]
/dev/sr0 /cd-rom pfs-iso9660 ro,suid 0 0
example: /home/user /home/user pfs-nfs ro,hard,fg 0 0
WARNINGS [Toc] [Back]
PFS is obsolete and no longer supported on any HP-UX release.
Delivery of PFS interfaces will be discontinued in the next HP-UX
PFS, from Young Minds, Inc. (now defunct), was originally adopted by
HP to provide accessibility to Rock Ridge Interchange file system
format on CD-ROM file systems. The equivalent functionality is now
provided via the HP-UX CDFS file system type and HP-UX's standard file
PFS has known functionality and performance problems. HP customers
are urged to stop using the PFS interfaces, including these
interfaces, /etc/pfs_fstab and /etc/mtab. Customers should move to
accessing all CD-ROM file system formats by using the standard HP-UX
commands, specifying the file system type as cdfs. For example, to
mount a CD-ROM file system, use:
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004
mount -F cdfs /dev/dsk/c0t0d4 /cdrom
There is no need to treat the cdfs file system type differently from
any other file system type, therefore no special daemons or commands
are required to access the variety of CD-ROM file system formats.
See mount(1M) and mount_cdfs(1M).
AUTHOR [Toc] [Back]
pfs_fstab was developed by Young Minds, Inc.
FILES [Toc] [Back]
SEE ALSO [Toc] [Back]
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: Sep 2004 [ Back ]