NAME [Toc] [Back]
Audio - audio tools available through HP VUE
DESCRIPTION [Toc] [Back]
This man-page describes the audio tools available through HP VUE for
playing, recording, and editing sound. These include Audio Setup,
Audio Security, Audio Editor, Audio Control Panel, Audio File and Data
Formats, and Audio Library. Audio(5) also provides information on
using other audio tools from the HP-UX command line.
Audio Setup Requirements [Toc] [Back]
To use the audio tools, you need access to both audio client and
server software. This software is part of HP-UX. The server
requires a workstation or X station with Audio hardware.
Audio hardware is built into all Series 700 computers except the 720,
730, and 750; you can upgrade these models to become the 725, 735, or
755, which do have audio hardware. Note, older 705s (that is, 705s
with the 8MB HP-UX) do not include audio software.
To use audio on an X station, you need either an HP ENVIZEX or ENTRIA
X station that includes an audio accessory kit.
In most cases, you use the audio client and server software on one
system. However, if you need the audio server running on a remote
workstation or X station, see aserver(1M). The audio data files can
reside on either system or a third system.
Audio Security [Toc] [Back]
Audio is secured to allow access only to the user on the local
workstation. If you need to allow remote systems to access audio on a
workstation, see asecure(1M).
The Audio Editor [Toc] [Back]
The Audio Editor is an OSF/Motif-based tool with play, record, and
edit functions. The Editor displays a waveform that makes it easy to
edit and play audio segments.
You can open an audio file, play it, look at its waveform, and use the
waveform controls to edit the file. To set an output device, use the
Audio Control Panel.
To record audio, first connect a microphone or other audio equipment
that your system supports; perhaps a CD or tape player. To make the
connections, see the Audio Editor online help ("Audio Editor Tasks"
section) or your system owner's manual.
You can use the Editor to create and record an audio file.
To start the Editor from the General Toolbox, open the Media
Toolbox and drop an audio file on the Audio Editor control
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
or double-click the control.
To start the Editor in a terminal window, type the
Online help is available through the Help menu in the upper-right hand
corner of the Editor.
The Audio Control Panel [Toc] [Back]
The Audio Control Panel is an OSF/Motif-based tool that you use to set
the audio volume and choose the audio device for playback.
The volume control affects the play volume for any client system of
this workstation or X station. The Audio Control Panel also includes
a Stop button to stop the current play operation.
You can also use the Audio Control Panel to choose the device for
playback, (headphones, built-in speaker, or device connected to Line
Out, such as external speakers). This choice controls where audio is
played when you double-click an audio file or use the Audio Editor to
play a file. The default output device is the internal (built-in)
To start the Audio Control Panel from HP VUE, click on the
Audio control in HP VUE Front Panel.
To start the Audio Control Panel in a terminal window, type
If your system has Audio applications that were developed using an
earlier version of Audio software, those applications may use the
SPEAKER environment variable to determine their output devices. You
can set the SPEAKER variable for all applications started by HP VUE by
modifying the $HOME/.vueprofile file. The SPEAKER variable can be
external (headphones, Line Out) or internal (built-in speaker).
To set the SPEAKER variable for a POSIX or Korn shell,
To set the SPEAKER variable for a C shell, enter:
setenv SPEAKER internal
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
Audio File and Data Formats [Toc] [Back]
Audio files supported contain uncompressed audio data in one of three
file formats: generic, RIFF/Waveform, or raw. Each file also needs
the correct filename extension. For the three file formats, the Audio
Editor online help lists which data formats and filename extensions
The extension causes the appropriate icon to appear in the File
Manager. To play audio files you can drag and drop the file icons
onto the Audio Editor or Control Panel or double-click the icon.
If you need to add an extension to a filename, (or convert the file
format) the /opt/audio/bin/convert command is recommended. See
convert(1). However, you can instead rename the file to make it
playable. Use this filename format:
The rate and data_type variables accept values defined for the -drate
and -ddata options of convert. If needed, you can omit the rate
variable. Use this filename format:
Audio Library [Toc] [Back]
HP-UX includes an Audio Library that was used to build the audio
tools. If you have ordered and installed the User Environment
Developer's Kit, you can use the Audio Library to create other audio
The HP-UX Audio Library contains functions that C programs can use to
manipulate audio. The functions interact with the Audio Server,
enabling the application to record and play audio data files and
convert audio data files from one format to another.
For more information about audio programming, refer to the manual
Using the Audio Developer's Kit.
AUTHOR [Toc] [Back]
The Audio Library, Audio Editor, and Audio Control Panel were
developed by HP.
SEE ALSO [Toc] [Back]
asecure(1M), aserver(1M), attributes(1), convert(1), send_sound(1).
Using the Audio Developer's Kit
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003 [ Back ]