NAME [Toc] [Back]
system - system description configuration files
DESCRIPTION [Toc] [Back]
The HP-UX system description file describes kernel configuration
information used by the kconfig(1M) and mk_kernel(1M) commands.
The system description file consists of the following information:
+ A line specifying the version of the system file.
+ The list of packaged and traditional kernel modules to be
+ Planned values for system tunable parameters, and other
system-wide configuration information.
Lines starting with an asterisk (*) are comment lines. HP discourages
adding comments to the system description file, since they are not
preserved by kernel configuration commands. See kconfig(5) for
HP-UX System Description File [Toc] [Back]
System files may contain a line specifying which version of the system
file syntax was used when writing the file. If present, this line must
be the first non-comment line of the system description file. This is
the only line in the system description file that must occupy a
particular position. All other lines are position independent. This
line has the following format:
where the following values for version are allowed:
1 The system file is formatted as described in this manual page.
0 The system file is formatted in the fashion used in HP-UX 11i
Version 1.6 and prior. This value is the default if no
version line appears in the system file.
New system files should always be created using version 1 of the
system file syntax. Support for version 0 will be removed in a future
System files that are generated by the kernel configuration commands
will contain a line indicating which configuration is being described.
This line has the form:
configuration name title timestamp
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: Sep 2004
name is the name of the configuration,
title is the title of the configuration (in quotes), and
timestamp indicates the time at which the system file was
System files may contain lines that list the traditional and packaged
kernel modules (including device drivers and pseudo-drivers) that are
to be configured.
Each such line has one of the following two formats:
module where module is either a traditional or packaged kernel
For example, scsi selects the driver for SCSI disk drives,
scsitape selects the driver for SCSI tape drives, and nfs
selects the NFS subsystem. This line format is for backward
compatibility. It does not allow specification of the state
of the module; the module state will be the default state as
given by the module's developer. To specify the desired
state of the module, use the second format.
module module state [version]
where module is either a traditional or packaged kernel
module name. state is one of best, static, auto or loaded;
see kcmodule(1M) for definitions of these states.
version is version of the module. The version field is
optional. It should generally be omitted when manually
editing or creating system files. It is used by kconfig -e
and kconfig -i when cloning kernel configurations; see
kconfig(1M) for details.
module scsi static [3E0D0C96]
selects the driver for SCSI disk drives.
module pseudodrv loaded 0.1.0
dynamically loads the module pseudodrv.
System files may also contain lines that are used to:
+ define the swap device
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: Sep 2004
+ define the dump device(s)
+ provide an explicit binding a driver to a hardware path
+ define status and values of selected system parameters.
Lines are constructed as indicated below for each category.
+ Swap Device Specification
No more than one swap specification is allowed. If swap
specification is not given, then primary swap binding is set to
Default. On a system using the Logical Volume Manager (LVM),
Default is equivalent to lvol. On other systems, the Default is to
page to the root disk, in the area between the end of the root file
system and the end of the disk.
swap hw_path offset [blocks]
Configure the swap device location and its size as
specified. Arguments are interpreted as follows:
hw_path The hardware path representing the device
to configure as the swap device or the
string default may be used to indicate
using the root device.
offset The swap area location. Boundaries are
located at 1K-byte intervals. A negative
value specifies that a file system is
expected on the device. At boot-up, the
super block is read to determine the exact
size of the file system, and this value is
put in offset. If the swap device is
auto-configured, this is the mechanism
used. If the super block is invalid, the
entry will be skipped so that a corrupted
super block will not later cause the
entire file system to be corrupted by
configuring the swap area on top of it. A
positive or zero value for offset
specifies the minimum area that must be
reserved. Zero means to reserve no area
at the head of the device. A zero value
implies that there is no file system on
blocks The number (in decimal) of 1K-byte disk
blocks in the swap area. For this swap
device specification, only the blocks
parameter is optional. Zero is the
default for auto-configuration. If blocks
is zero, the entire remainder of the
device is automatically configured in as
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: Sep 2004
swap area. If blocks is non-zero, its
absolute value is treated as an upper
bound for the size of the swap area.
Then, if the swap area size has actually
been cut back, the sign of blocks
determines whether blocks remains as is,
resulting in the swap area being adjacent
to the reserved area, or whether blocks is
bumped by the size of the unused area,
resulting in the swap area being adjacent
to the tail of the device.
swap lvol Configure swap on a logical volume.
swap none Configure the kernel with no swap device.
+ Dump Device Specifications
One or more dump specifications are allowed. If a dump
specification is not given, then the primary swap area will be
dump hw_path Configure the dump device location and its size as
specified. hw_path is the hardware path
representing the device to configure as a dump
device or the string default may be used to indicate
using the primary swap area.
dump lvol Configure dump on a logical volume.
dump none Configure the kernel with no dump device.
+ Explicit Device Driver Bindings
One or more driver to hardware path specifications is allowed. If
a driver statement is provided, the specified software module is
forced into the kernel I/O system at the given hardware path. This
can be used to make the system recognize a device that could not be
driver hw_path driver_name
Bind the driver into the kernel I/O system at the
given hardware path. Arguments are interpreted as
hw_path The hardware path representing the
device to bind the software with.
driver_name The name of the software module to
bind into the kernel at the specified
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: Sep 2004
+ Kernel Tunable Parameter Settings
These lines contain the values (other than default) of kernel
tunable parameters that will be used for the kernel configuration.
A tunable value can be either a number or a formula, but it cannot
contain whitespace. If the tunable is user defined, then
parameter_name is preceded by the keyword user:. No whitespace is
permitted between user: and parameter_name. Each line has the
[tunable] [user:]parameter_name value
Modular System File [Toc] [Back]
Modular system files have been removed from the HP-UX configuration
paradigm. All the required information from modular system files have
been merged into the traditional system file itself thus creating a
single hpux system description file.
FILES [Toc] [Back]
/stand/system HP-UX system description file for the
nextboot kernel configuration
/stand/config/system HP-UX system description file for the
kernel configuration named config
SEE ALSO [Toc] [Back]
kconfig(1M), kctune(1M), mk_kernel(1M), kconfig(5).
Hewlett-Packard Company - 5 - HP-UX 11i Version 2: Sep 2004 [ Back ]