NAME [Toc] [Back]
runacct - run daily accounting
SYNOPSIS [Toc] [Back]
DESCRIPTION [Toc] [Back]
runacct is the main daily accounting shell procedure. It is normally
initiated via cron(1M). runacct processes connect, fee, disk, and
process accounting files. It also prepares summary files for prdaily
or billing purposes.
runacct takes care not to damage active accounting files or summary
files in the event of errors. It records its progress by writing
descriptive diagnostic messages into active. When an error is
detected, a message is written to /dev/console, mail (see mail(1),
mailx(1), or elm(1)) is sent to root and adm, and runacct terminates.
runacct uses a series of lock files to protect against re-invocation.
The files lock and lock1 are used to prevent simultaneous invocation,
and lastdate is used to prevent more than one invocation per day.
runacct breaks its processing into separate, restartable states using
statefile to remember the last state completed. It accomplishes this
by writing the state name into statefile. runacct then looks in
statefile to see what it has done and to determine what to process
next. states are executed in the following order:
SETUP Move active accounting files into working files.
WTMPFIX Verify integrity of wtmp file, correcting date
changes if necessary.
CONNECT Produce connect session records in tacct.h format.
PROCESS Convert process accounting records into tacct.h
MERGE Merge the connect and process accounting records.
FEES Convert output of chargefee into tacct.h format
and merge with connect and process accounting
DISK Merge disk accounting records with connect,
process, and fee accounting records.
MERGETACCT Merge the daily total accounting records in
daytacct with the summary total accounting records
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
CMS Produce command summaries.
USEREXIT Any installation-dependent accounting programs can
be included here.
CLEANUP Cleanup temporary files and exit.
To restart runacct after a failure, first check the active file for
diagnostics, then fix up any corrupted data files such as pacct or
wtmp. The lock files and lastdate file must be removed before runacct
can be restarted. The argument mmdd is necessary if runacct is being
restarted, and specifies the month and day for which runacct will
rerun the accounting. Entry point for processing is based on the
contents of statefile; to override this, include the desired state on
the command line to designate where processing should begin.
EXAMPLES [Toc] [Back]
To start runacct.
nohup runacct 2> /var/adm/acct/nite/fd2log &
To restart runacct.
nohup runacct 0601 2>> /var/adm/acct/nite/fd2log &
To restart runacct at a specific state.
nohup runacct 0601 MERGE 2>> /var/adm/acct/nite/fd2log &
WARNINGS [Toc] [Back]
Normally it is not a good idea to restart runacct in its SETUP state.
Run SETUP manually, then restart via:
runacct mmdd WTMPFIX
If runacct failed in its PROCESS state, remove the last ptacct file
because it will not be complete.
FILES [Toc] [Back]
SEE ALSO [Toc] [Back]
mail(1), acct(1M), acctcms(1M), acctcom(1M), acctcon(1M),
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
acctmerg(1M), acctprc(1M), acctsh(1M), cron(1M), fwtmp(1M), acct(2),
STANDARDS CONFORMANCE [Toc] [Back]
runacct: SVID2, SVID3
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003 [ Back ]