NAME [Toc] [Back]
rstatd - kernel statistics server
SYNOPSIS [Toc] [Back]
/usr/lib/netsvc/rstat/rpc.rstatd [-l log_file] [-e|-n]
DESCRIPTION [Toc] [Back]
rstatd is an RPC server that returns performance statistics obtained
from the kernel. The rup utility prints this information (see
inetd invokes rstatd through /etc/inetd.conf (see inetd(1M)).
Options [Toc] [Back]
rstatd recognizes the following options and command-line arguments:
-l log_file Log any errors to the named log file, log_file.
Errors are not logged if the -l option is not
Information logged to the file includes date and
time of the error, the host name, process ID and
name of the function generating the error, and the
error message. Note that different services can
share a single log file because enough information
is included to uniquely identify each error.
-e Exit after serving each RPC request. Using the -e
option, the inetd security file /var/adm/inetd.sec
can control access to RPC services.
-n Exit only if
+ portmap dies (see portmap(1M)),
+ another rpc.rstatd registers with portmap,
+ rpc.rstatd becomes unregistered with
The -n option is more efficient since a new
process is not launched for each RPC request.
Note, this option is the default.
AUTHOR [Toc] [Back]
rstatd was developed by Sun Microsystems, Inc.
SEE ALSO [Toc] [Back]
rup(1), inetd(1M), portmap(1M), inetd.conf(4), inetd.sec(4),
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003 [ Back ]