NAME [Toc] [Back]
kclog - manage kernel configuration log file
SYNOPSIS [Toc] [Back]
kclog [-a] [-c config] [-f string] [-t type] [-n name] [count]
kclog -C comment
DESCRIPTION [Toc] [Back]
kclog is the administrative command for the HP-UX kernel configuration
log file. The log file is automatically maintained by all of the
kernel configuration commands (kconfig(1M), kcmodule(1M), and
kctune(1M)). Any change to any kernel configuration gets logged to
this log file, which is located at /var/adm/kc.log. Note that this
file is a plain text file which can be viewed and manipulated using
standard Unix file management commands; kclog exists simply for
convenience in finding particular log file entries.
Under normal usage, kclog prints the last count entries in the log
file. When one of the options is specified, kclog prints the last
count entries that match the specified criteria. If count is not
specified, it defaults to 1.
Options [Toc] [Back]
-a kclog will print all entries matching criteria. If
this option is not specified, kclog will only print the
last count entries that match the specified criteria.
-c config kclog will print only log file entries describing
changes to the saved kernel configuration named config.
If this option is not specified, kclog will print log
file entries describing changes to any saved or running
-C comment kclog will not print any entries. Instead, kclog will
create a new entry, as if a kernel configuration change
had been made, containing the specified comment.
Super-user permissions are required for this option.
-f string kclog will print only log file entries that contain the
-n name kclog will print only log file entries that refer to a
configuration object (module or tunable) of the given
-t type kclog will print only log file entries that refer to
configuration objects of the specified type: module or
RETURN VALUE [Toc] [Back]
kclog returns zero for success. It returns non-zero and prints a
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
diagnostic message if an error occurs.
EXAMPLES [Toc] [Back]
To see the last three entries in the log:
$ kclog 3
To see the last entry for the tunable file_sys_max:
$ kclog -t tunable -n file_sys_max
To see the last five entries for module changes:
$ kclog -t module 5
To see all entries for module changes:
$ kclog -a -t module 5
To see the last entry mentioning Aberdeen:
$ kclog -f Aberdeen
WARNINGS [Toc] [Back]
The format of the log file may be changed without notice.
Some configuration changes can be made without using the kernel
configuration commands. No log file entries are made for such
The log file should not be manually edited. Doing so may cause kclog
to behave unpredictably.
SEE ALSO [Toc] [Back]
kconfig(5), kcmodule(1M), kconfig(1M), kctune(1M).
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003 [ Back ]