NAME [Toc] [Back]
localedef - generate a locale environment
SYNOPSIS [Toc] [Back]
localedef [-cenvw] [-C compiler_options] [-L loader_options]
[-m method_file] [-f charmap_file] [-i locale_definition]
DESCRIPTION [Toc] [Back]
localedef sets up the language environment for the named locale.
localedef reads a locale definition file (see localedef(4) for a
detailed description) from standard input (default) or from
locale_definition file, creates a locale file with the same name as
specified for the locale_name parameter, and optionally installs this
locale in the appropriate directory. Installation of public locales
(those accessible to all users) requires appropriate privileges.
Creation of locales (both private and public) requires access to the
ANSI C compiler.
Options [Toc] [Back]
localedef recognizes the following options:
-c Create permanent output even if warning messages have
-e Generate 64-bit locale in addition to the 32-bit
locale. This is the default on a 64-bit operating
system (and hence on Itanium(R)-based systems) and is
included to allow cross platform development.
-n (noinstall) Create the locale file in the current
-v (verbose) Generate as many diagnostic messages as
-w Generate additional warning messages for duplicate
definitions and ellipses use in the LC_COLLATE
If locale definition file contains symbolic names (of
the form <name>) use charmap_file. See charmap(4) for
a description of the format of a charmap_file.
Use locale_definition file as input, instead of
standard input (default).
Hewlett-Packard Company - 1 - HP-UX 11i Version 2: August 2003
-m method_file Use the specified method_file to overwrite use of
default methods in processing the locale definition.
Specify additional compiler options to be applied in
compiling the locale. See cc_bundled(1) for a complete
list of options. Use with care on a 64-bit operating
system since the additional default option includes
+DA2.0W on PA-RISC and +DD64 on Itanium-based systems.
Specify additional loader options to be applied in
linking the locale. See ld(1) for a complete list of
locale_name This argument is required, and identifies the name of
the language following the naming convention of the
LANG environment variable (see environ(5)):
The following is a brief description of the components that make up a
locale. For a complete description of the form and syntax of a locale
definition file, see localedef(4). For a complete description of the
form and effects of a charmap file, see charmap(4).
Six categories of data in the locale_name file are recognized by
setlocale(3C), and make up a language definition:
LC_COLLATE Information in this category affects behavior
of regular-expressions and NLS stringcollation
LC_CTYPE Information in this category affects behavior
of character classification and conversion
LC_MONETARY Information in this category affects behavior
of functions that handle monetary values.
LC_NUMERIC Information in this category affects handling
of the radix character in formattedinput/output
and string-conversion functions.
LC_TIME Information in this category affects behavior
of time-conversion functions.
LC_MESSAGES This category contains information affecting
interpretation of yes/no responses.
Hewlett-Packard Company - 2 - HP-UX 11i Version 2: August 2003
A locale definition file also consists of six categories. The
beginning of each category is identified by a category tag having the
form LC_category where category is one of the following: CTYPE,
COLLATE, MONETARY, NUMERIC, TIME, or MESSAGES. The end of each
category is identified by a tag consisting of the word END followed by
a space and the category identifier; for example, END LC_COLLATE.
Categories can appear in any order in the locale definition file. At
least one category specifications is required. If a category is not
specified, setlocale() sets up the default ``C'' locale for that
category (see setlocale(3C) and lang(5)).
Each category is composed of one or more statements. Each statement
begins with a keyword followed by one or more expressions. An
expression is a set of well-formed metacharacters, strings, and
constants. localedef also recognizes comments and separators.
More than one definition specified for each category constitutes a
hard error (causes localedef to exit without generating a locale).
Any category can be specified by the keyword copy followed by the name
of a valid locale. This causes the information for the category to be
identical to that in the named locale. Note that the copy keyword, if
used for a category, must be the first and only keyword following the
A methods file is used to create locales for user-specific character
Operating System Requirements [Toc] [Back]
For cross platform development and development on a 64-bit operating
system several requirements must be observed. Both the 32-bit and 64-
bit method libraries must exist. In the case of the 64-bit shared
library it must be in the directory ../hpux64 ( or pa20_64 in case of
PA-RISC systems) under the location where the 32-bit library is
located. When the -e option is specified, or when executing on a 64-
bit operating system, the resulting locale is placed in the directory
hpux64 (pa20_64 in case of PA-RISC systems) under the current working
directory unless the install option has been specified.
Note [Toc] [Back]
A locale built for one system cannot be used on other systems.
Users will not be able to generate PA-RISC locales on Itanium-based
EXTERNAL INFLUENCES [Toc] [Back]
LANG determines the locale to use when neither LC_ALL or the other
category variables specify a locale.
LC_ALL determines locale to be used. It overrides any values
specified by LANG or any other LC_* variables.
Hewlett-Packard Company - 3 - HP-UX 11i Version 2: August 2003
LC_COLLATE and LC_CTYPE have no effect on the processing of localedef,
which behaves as if these two variables were set to the C locale.
LC_MESSAGES determines the language in which messages are displayed.
International Code Set Support [Toc] [Back]
Single- and multi-byte character code sets are supported.
RETURN VALUE [Toc] [Back]
localedef returns the following values:
0 No errors occurred and the locale was successfully created.
1 Warnings occurred and the locale was successfully created.
2 The locale specification exceeded implementation limits or
the coded character set used is not supported.
>3 Warnings or errors occurred, and no output was generated.
AUTHOR [Toc] [Back]
localedef was developed by OSF and HP.
FILES FOR PA-RISC SYSTEMS [Toc] [Back]
FILES FOR ITANIUM-BASED SYSTEMS [Toc] [Back]
In addition to the PA-RISC files, the following files are present on
SEE ALSO [Toc] [Back]
locale(1), setlocale(3C), charmap(4), localedef(4), environ(5).
STANDARDS CONFORMANCE [Toc] [Back]
localedef: XPG4, POSIX.2
Hewlett-Packard Company - 4 - HP-UX 11i Version 2: August 2003 [ Back ]